Results 1 to 4 of 4
  1. #1
    Join Date
    May 2003
    Location
    Florida
    Posts
    192

    "last login" in cpanel control panel always says "locla host"

    Hi All,

    In cpanel, in all skins, across all users accounts, "last login" always says cpanel. i sent an email to support [this is a dedicated server] and they replied:

    In case of localhost in last login the cpanel forums shows these details

    =====
    This is down to using STunnel instead of building their own SSL engine, or integrating someone elses.

    STunnel just creates and handles the SSL chat with the end-user browser, then forwards the unencrypted traffic over the localhost; hence as far as cpanel is concerned, all logins come from localhost (127.0.0.1)
    =====
    does this sound right? their saying nothin can be done about it.

    thx for any feedback/suggestions.

  2. #2
    Join Date
    Jul 2003
    Location
    Nothing but, net
    Posts
    2,062
    Everything is working as it should...

    You are connecting via SSL to cPanel.

    What is actually happening is as follows.

    You are connecting via port 2087 to the stunnel daemon, it encryptions communication from you to the server and from the server to you on port 2087. Stunnel then opens a connection from 127.0.0.1 to 127.0.0.1:2086 and relays the information unencrypted.

    Nothing is broken. All is well.

  3. #3
    Join Date
    May 2003
    Location
    Florida
    Posts
    192
    thx for relaying that in laymens terms.

    it makes a whole heck of a lot more sense.

    muchos gracias.

  4. #4
    Join Date
    Feb 2004
    Posts
    772
    Hi,

    Yes you are right. That is the main cause.

    Regards,

    Bright

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •