Results 1 to 17 of 17
  1. #1
    Join Date
    Dec 2000
    Posts
    951

    Question Have 2 "named" running on server

    hi all,

    I have 2 "named" service running on same time on a server.
    Not sure but on other servers have only 1
    Anyone can tell me what's wrong ? and how shut down one of them?

    Thanks a lot
    =============
    1:19pm up 39 min, 1 user, load average: 0.71, 0.97, 0.94
    77 processes: 73 sleeping, 4 running, 0 zombie, 0 stopped
    CPU states: 17.2% user, 12.4% system, 0.0% nice, 70.4% idle
    Mem: 902956K av, 446300K used, 456656K free, 0K shrd, 95440K buff
    Swap: 763076K av, 0K used, 763076K free 216312K cached

    PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
    3132 named 16 0 9460 9460 1980 S 12.1 1.0 3:40 named
    3134 named 11 0 9460 9460 1980 R 4.7 1.0 2:11 named
    8879 nobody 9 0 22992 22M 3756 S 3.9 2.5 0:00 httpd
    8886 nobody 18 0 23108 22M 3828 S 2.1 2.5 0:00 httpd
    9489 mailnull 10 0 2768 2768 2072 S 0.7 0.3 0:00 exim

  2. #2
    Join Date
    Dec 2000
    Posts
    951
    hmm it seems that this 2 named running the same time using lot of cp load:
    =========
    named 10.51 12.65 0.0
    Top Process %CPU 11.2 named -u named
    Top Process %CPU 10.4 named -u named
    ========

    Any way to disable 1 of them??

  3. #3
    Join Date
    Jun 2002
    Posts
    1,376
    It's odd that they're both taking a good deal of CPU, however, I believe named is a multi-threaded app, and you'll thus get more than one instance sometimes. In fact, it looks like I've got six processes going (by running ps aux | grep named). It's pretty normal, like how Apache has a zillion copies of itself going to deal with visitors.

  4. #4
    Join Date
    Dec 2000
    Posts
    951
    ok...but this cp usage it is just a bit too high...
    probably this is comming up afhter the kernel upgrade.
    Ia there any way to "tweak out" something ?

  5. #5
    Join Date
    Apr 2002
    Location
    Philly Pa
    Posts
    130
    you shouldnt have 2, check your /var/log/messages or /var/log/deamon to see if 1 is giving you "socket in use"

    i would kill them both and start up one again.

  6. #6
    Join Date
    Nov 2002
    Posts
    510
    Just kill the processes, and restart named (through whatever init script is on your server) -- or a reboot if you'd rather not manually kill it.

    If it's still like that afterwards, then you have to investigate.

  7. #7
    Join Date
    Dec 2000
    Posts
    951
    I cannot kill them via SSH but via WHM. But afhter kill the process (no mather wich one) the nameserver is completaly down and i had to restart it.
    In other words or both or nothing.....

    Any other suggestion to fix?

  8. #8
    Join Date
    Nov 2002
    Posts
    510
    What do you mean you can't kill them via SSH?

    It's fine that there are two -- my named runs 5 processes -- it's normal to have a threaded named. The problem was more with how much CPU each was using -- that is not normal, and it's not good.

    Are they still using that much CPU?

  9. #9
    Join Date
    Dec 2000
    Posts
    951
    cubision--- yest they are still using that much CPU
    I just check /var/log/messages and found tons of the following inside (about 23 thousend lines..) all the same error with the same domain:
    -----
    Feb 1 05:37:05 servername named[3100]: lame server resolving 'domainame.com' (in 'domainame.COM'?): 12.34.56.78#53
    -----

    Do you know what's wrong? This was an account i have cancell 3 days ago. It was runngin a free based webmail service.

    Thanks a lot

  10. #10
    Join Date
    Dec 2000
    Posts
    951
    ok found the problem...
    probably it's because the main domain.com had domain.net as pointed domain. Since i delete the main account "domain.com" request's are going still to the domain.net and perhaps that created some confusion. As soon as i backup the main account domain.com all goes fine for cpu load and named.
    However as the domain was a free webmail service i hade a lot of trouble with the recent virus. As soon as i backup the account exim put's the server load over 100.00 !!! and i found more that 250 mail in queue in only 60 seconds! So I had temporarly to disable exim on server.
    I will now try do unpark first the parked domain and then delet the main account. Then unsuspend exim. Hope this will be the final step of this story.

    Thanks to all for your help.

  11. #11
    Join Date
    Dec 2003
    Location
    Boston, MA
    Posts
    602
    I would always run named with named -u bind -g bind -c /etc/namedb/named.conf


    -u and -g being the uid and gid. This way those problems wont arise. There will be 0% confusion
    Axcelx Technologies - James
    Boston Colocation | Boston VPS
    Massachusetts Server Colocation and Dedicated Servers

  12. #12
    Join Date
    Dec 2000
    Posts
    951
    yeah "crucial" ther is still something wrong with bind. Have till the error in messages:
    ---------
    Feb 1 05:37:05 servername named[3100]: lame server resolving 'domainame.com' (in 'domainame.COM'?): 12.34.56.78#53
    ---------

    sorry , I am not sure but can i do this settings in the .conf of bind?

    Thanks

  13. #13
    Join Date
    Dec 2000
    Posts
    951
    not sure but there seems to be a problem on nameserver on wich was hosted this domain as these errors are reffering to those 2 nameserver IP's:
    -------
    Feb 1 05:37:05 servername named[3100]: lame server resolving 'domainame.com' (in 'domainame.COM'?): 12.34.56.78#53
    -------
    Feb 1 05:37:05 servername named[3100]: lame server resolving 'domainame.com' (in 'domainame.COM'?): 12.34.56.79#53
    -----

  14. #14
    Join Date
    Dec 2000
    Posts
    951
    nobody have a fix for this problem?
    Last edited by WWWhost; 02-02-2004 at 11:19 AM.

  15. #15
    Join Date
    Dec 2003
    Location
    Boston, MA
    Posts
    602
    I'll fix give me root j/k

    Go into the config and check for that domainname.com if thats not a domain you own remove its justifications.

    Maybe you should post your config here and I can better assist you.
    Axcelx Technologies - James
    Boston Colocation | Boston VPS
    Massachusetts Server Colocation and Dedicated Servers

  16. #16
    Join Date
    Dec 2000
    Posts
    951
    yeah i'll send you a packege with a gift and my root PW..hehe

    let's goe seriouse.... just read about lame servers and think adding the following into named.conf should fix the problem
    -------
    logging {
    category lame-servers { null; };
    //category queries { default_syslog; default_debug; };

    };
    -----
    not sure if it does but i will try it out.

  17. #17
    Join Date
    Dec 2000
    Posts
    951
    nono ... it does not work... any other way to redirect lame server request's elswhere?

  18. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •