hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : SSL stoped working
Reply

Forum Jump

SSL stoped working

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 09-01-2003, 05:27 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
Question

SSL stoped working


My SSL server stoped working today and I don't know why.

It was working yesterday.

I checked the logs and nothing special there.

Can somebody tell me what else I have to do and check to make it work?

Thanks in advance

__________________
How's my programming? Call 1-800-DEV-NULL



Sponsored Links
  #2  
Old 09-01-2003, 05:32 PM
SROHost SROHost is offline
Web Hosting Master
 
Join Date: Jan 2003
Location: Lake Arrowhead, CA
Posts: 789
What logs did you check? The apache error log or SSL log? It depends what you use for SSL, but Apache with mod_ssl will default to putting SSL logs in the apache log directory with names ssl_engine_log and ssl_request_log.

__________________
http://www.srohosting.com
Stability, redundancy and peace of mind

  #3  
Old 09-01-2003, 05:43 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
This is a Cpanel server and SSL logs are located in /var/log

So i checked the log and found this

Quote:
[01/Sep/2003 16:39:13 32173] [info] Init: Loading certificate & private key of SSL-aware server secure.www-lab.com:443
[01/Sep/2003 16:39:14 32174] [info] Init: Configuring server secure.www-lab.com:443 for SSL protocol
[01/Sep/2003 16:39:27 32180] [info] Connection to child 0 established (server secure.www-lab.com:443, client 67.167.41.130)
[01/Sep/2003 16:39:27 32180] [info] Seeding PRNG with 1160 bytes of entropy
[01/Sep/2003 16:39:27 32180] [info] Connection: Client IP: 67.167.41.130, Protocol: SSLv3, Cipher: RC4-MD5 (128/128 bits)
[01/Sep/2003 16:39:27 32180] [info] Initial (No.1) HTTPS request received for child 0 (server secure.www-lab.com:443)
[01/Sep/2003 16:39:27 32180] [info] Connection to child 0 closed with unclean shutdown (server secure.www-lab.com:443,
client 67.167.41.130)
[01/Sep/2003 16:39:29 32181] [info] Connection to child 1 established (server secure.www-lab.com:443, client 67.167.41.130)
[01/Sep/2003 16:39:29 32181] [info] Seeding PRNG with 1160 bytes of entropy
[01/Sep/2003 16:39:29 32181] [info] Connection: Client IP: 67.167.41.130, Protocol: SSLv3, Cipher: RC4-MD5 (128/128 bits)
[01/Sep/2003 16:39:29 32181] [info] Initial (No.1) HTTPS request received for child 1 (server secure.www-lab.com:443)
[01/Sep/2003 16:39:29 32181] [info] Connection to child 1 closed with unclean shutdown (server secure.www-lab.com:443,
client 67.167.41.130)
What's wrong with this SSL host?

Thanks

__________________
How's my programming? Call 1-800-DEV-NULL

Sponsored Links
  #4  
Old 09-01-2003, 05:52 PM
ravegti1 ravegti1 is offline
WHT Addict
 
Join Date: Aug 2003
Posts: 129
maybe the cert expired?

  #5  
Old 09-01-2003, 05:53 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
No, it expires in January

__________________
How's my programming? Call 1-800-DEV-NULL

  #6  
Old 09-01-2003, 11:04 PM
sprintserve sprintserve is offline
Retired Moderator
 
Join Date: Jan 2003
Posts: 9,004
Run ps -aux

check your apache process. Do they have -DSSL switch?

If not, try

/etc/init.d/httpd stop
/etc/init.d/httpd start

__________________
Like us on Facebook to qualify for discounts!
http://www.sprintserve.net
Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
Services: | Managed Multiple Cores 64bit Servers | Server Management |

  #7  
Old 09-01-2003, 11:22 PM
eddy2099 eddy2099 is offline
Web Hosting Master
 
Join Date: May 2001
Posts: 8,070
Expired SSL will still run but just issue a warning to the browser.

  #8  
Old 09-01-2003, 11:28 PM
sprintserve sprintserve is offline
Retired Moderator
 
Join Date: Jan 2003
Posts: 9,004
Quote:
Originally posted by eddy2099
Expired SSL will still run but just issue a warning to the browser.
exactly. it's likely to be apache's issue

__________________
Like us on Facebook to qualify for discounts!
http://www.sprintserve.net
Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
Services: | Managed Multiple Cores 64bit Servers | Server Management |

  #9  
Old 09-01-2003, 11:31 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
It was an apache issue. I don't know how, but the DocumentRoot was pointing to directory other from the one I had before.

Thank you guys for technical support

Need some coffee ...

__________________
How's my programming? Call 1-800-DEV-NULL

  #10  
Old 09-01-2003, 11:35 PM
sprintserve sprintserve is offline
Retired Moderator
 
Join Date: Jan 2003
Posts: 9,004
DocumentRoot? that's a configuration in httpd.conf. Is it for a particular virtual domain or for the whole server?

Another simple way is just to reinstall the SSL cert.

__________________
Like us on Facebook to qualify for discounts!
http://www.sprintserve.net
Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
Services: | Managed Multiple Cores 64bit Servers | Server Management |

  #11  
Old 09-01-2003, 11:39 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
Yes, it is for virtual host, it all works now

__________________
How's my programming? Call 1-800-DEV-NULL

  #12  
Old 09-01-2003, 11:41 PM
sprintserve sprintserve is offline
Retired Moderator
 
Join Date: Jan 2003
Posts: 9,004
Ok. Glad it works out. Cheers.

__________________
Like us on Facebook to qualify for discounts!
http://www.sprintserve.net
Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
Services: | Managed Multiple Cores 64bit Servers | Server Management |

  #13  
Old 09-01-2003, 11:42 PM
null null is offline
Web Hosting Master
 
Join Date: Sep 2002
Location: Illinois
Posts: 2,305
Thanks for help

__________________
How's my programming? Call 1-800-DEV-NULL

  #14  
Old 11-11-2004, 03:20 PM
chico540 chico540 is offline
Newbie
 
Join Date: Feb 2002
Posts: 26
i have the same problem but the do root looks to be ok. should i switch this domain to a dedicated ip address rather than shared? im usin cpanel server too....
thanks

__________________
Webhosting with cPanel / WHM. Feature packed Reseller, Shared, and Adult Web Hosting plans.
www.getwhp.com

Reply

Related posts from TheWhir.com
Title Type Date Posted
More Downtime for HostGator and BlueHost Customers as Router Issues Plague Utah Data Center Web Hosting News 2014-04-16 15:46:56
Healthcare.gov Hosting to Switch from Terremark to HP: Reports Web Hosting News 2013-11-29 11:53:39
European Data Center Association Forms Groups to Address Power, Data Center Control Issues Web Hosting News 2013-04-10 12:15:48
Netflix Outage Caused by EC2 Downtime: Reports Web Hosting News 2012-12-24 21:05:12
Ecommerce Platform Magento Emphasizes Quality with New Web Host Partner Program Web Hosting News 2012-11-12 13:28:42


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?