hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Dedicated Server : mod_rewrite - htaccess - help
Reply

Forum Jump

mod_rewrite - htaccess - help

Reply Post New Thread In Dedicated Server Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 07-10-2003, 03:21 PM
gargonzo gargonzo is offline
Junior Guru Wannabe
 
Join Date: Dec 2001
Location: gulf of mexico
Posts: 52

mod_rewrite - htaccess - help


folks. trying to get mod rewrite to work so we can convert cgi to html. We are on a RAQ3, and it seems the htaccess file is not working...

even a basic htaccess with a redirect inside it does not work.. is there any info about getting htaccess to workin a raq3? or does anyone have any advice/help..

tia
garz



Sponsored Links
  #2  
Old 07-11-2003, 12:22 AM
gargonzo gargonzo is offline
Junior Guru Wannabe
 
Join Date: Dec 2001
Location: gulf of mexico
Posts: 52
access.conf has this:
Quote:

<Directory>
Options None
AllowOverride None
AuthFailDelay 2000000
</Directory>

# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.

# This should be changed to whatever you set DocumentRoot to.

<Directory /home/sites/>
ErrorDocument 400 /Error_Docs/400.html
ErrorDocument 401 /Error_Docs/401.html
ErrorDocument 403 /Error_Docs/403.html
ErrorDocument 404 /Error_Docs/404.html
ErrorDocument 500 /Error_Docs/500.html
ErrorDocument 501 /Error_Docs/501.html
ErrorDocument 502 /Error_Docs/502.html
ErrorDocument 503 /Error_Docs/503.html

# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".

# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.

Options Indexes FollowSymLinks Includes MultiViews

# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"

AllowOverride All

# ignore .ht*
<Files ".ht*">
allow from all
</Files>

# Controls who can get stuff from this server.

order allow,deny
allow from all

AuthFailDelay 2000000
</Directory>

# be more restrictive within a site
<Directory /home/sites/*/>
Options -FollowSymLinks +SymLinksIfOwnerMatch
</Directory>

# @@ServerRoot@@/cgi-bin should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.

#<Directory /home/httpd/cgi-bin>
#AllowOverride None
#Options ExecCGI
#</Directory>

# Allow server status reports, with the URL of http://servername/server-status
# Change the ".your_domain.com" to match your domain to enable.

#<Location /server-status>
#SetHandler server-status

#order deny,allow
#deny from all
#allow from .your_domain.com
#</Location>

# There have been reports of people trying to abuse an old bug from pre-1.1
# days. This bug involved a CGI script distributed as a part of Apache.
# By uncommenting these lines you can redirect these attacks to a logging
# script on phf.apache.org. Or, you can record them yourself, using the script
# support/phf_abuse_log.cgi.

#<Location /cgi-bin/phf*>
#deny from all
#ErrorDocument 403 http://phf.apache.org/phf_abuse_log.cgi
#</Location>
what needs to be changed in order for htaccess to work, send help

  #3  
Old 07-11-2003, 10:17 AM
D8Mike D8Mike is offline
WHT Addict
 
Join Date: Oct 2001
Posts: 134
Did you install the mysql_auth module in apache? I have seen in other posts that all htaccess are override by this module, so if you want to use a htaccess auth and you have it installed you need to add this line to htaccess:

AuthMySQL off
or
Auth_MySQL off

Also remember to always upload .htaccess files in Ascii Mode

You also might look at this thread
http://forum.rackshack.net/showthrea...ss+not+working

__________________
Mike


Last edited by D8Mike; 07-11-2003 at 10:28 AM.
Sponsored Links
  #4  
Old 07-13-2003, 07:53 AM
Cephren Cephren is offline
Registered User
 
Join Date: Jun 2001
Posts: 596
When you chaned the AllowOveride Command to All

did you restart apache?

Reply

Related posts from TheWhir.com
Title Type Date Posted
IBM Initiatives Attempt to Keep Mainframe Computing Relevant as It Turns 50 Web Hosting News 2014-04-09 14:23:08
SingleHop Adds Multi-Factor Authentication as Part of New Customer Feedback Initiative Web Hosting News 2014-03-25 11:39:00
Mistakes To Avoid When Launching A New Website Design Blog 2014-01-10 10:53:50
ProfitBricks Says its New “Next Generation Cloud” Outperforms Amazon, Rackspace Web Hosting News 2012-09-10 16:35:00
Web Host WebHostForASP.net Launches VPS Hosting Service Web Hosting News 2012-06-29 14:52:22


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?