Results 1 to 12 of 12
  1. #1
    Join Date
    Mar 2003
    Posts
    68

    Apache and all the staus are green, but sites are down

    Hi All,

    All the status are green, but sites are down. Apache is up and all are up.

    It happens very often, is anything wrogn with compilation??

    Thanks
    mokkan

  2. #2
    Join Date
    Mar 2002
    Location
    New York, NY
    Posts
    410
    While logged into the box, type:

    tail -f /usr/local/apache/logs/error_log

    and then:

    tail -f /var/log/messages

    Notice any unusual error's?
    Norm Sherman @ Netacore
    Fast/Reliable cPanel hosting on premium bandwidth
    http://netacore.com

  3. #3
    Join Date
    Feb 2003
    Location
    Providence, RI
    Posts
    1,512
    Actually, the green lights doesn't really mean that the service is up successfully.

    Do what netacore suggested and paste some of the unusual results here. The first thing appears at the top of my head is to make sure you have space for your web logs.

  4. #4
    Also make sure that it's really the server and not just your own local ISP routing issue.

    Check and see if the processes are running as well
    Like us on Facebook to qualify for discounts!
    http://www.sprintserve.net
    Offering: | Internap FCP Bandwidth! | Rebootless Kernel Updates! | Magento Optimized Hosting | Wordpress Hosting |
    Services: | Managed Multiple Cores 64bit Servers | Server Management |

  5. #5
    Join Date
    Mar 2003
    Posts
    68
    Thanks for your input.

    I checked both log files and couldn't find any unexpected erros. What should I have to check?. What is the correct tiem to check the log?

    Any help would be appreciated. Thsi is really annoyin ad lots of complaint.

    Any help would be appreciated.

    thanks

  6. #6
    Join Date
    Mar 2003
    Posts
    68
    I have to reboot the systedm after I found those lines one on
    /usr/local/apahce/logs

    [Mon Jun 16 22:44:14 2003] [error] mod_ssl: Child could not open SSLMutex lockfi
    le /usr/local/apache/logs/ssl_mutex.18780 (System error follows)
    [Mon Jun 16 22:44:14 2003] [error] System: No such file or directory (errno: 2)
    [Mon Jun 16 22:44:14 2003] [error] mod_ssl: Child could not open SSLMutex lockfi
    le /usr/local/apache/logs/ssl_mutex.18780 (System error follows)
    [Mon Jun 16 22:44:14 2003] [error] System: No such file or directory (errno: 2)
    [Mon Jun 16 22:44:14 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.2 mod_b
    wlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.14 OpenSSL/0.9.6b config
    ured -- resuming normal operations
    [Mon Jun 16 22:44:14 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/loca
    l/apache/bin/suexec)
    [Mon Jun 16 22:44:14 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)


    Plese help me.

    thanks

  7. #7
    Join Date
    Mar 2003
    Posts
    68
    Hi,

    Also get these errors.


    [Mon Jun 16 21:49:49 2003] [error] [client 61.187.51.42] no acceptable variant:
    /usr/local/apache/htdocs/index.html
    [Mon Jun 16 21:49:51 2003] [error] [client 24.64.223.203] File does not exist: /
    usr/local/apache/htdocs/storage/60x15.gif
    [Mon Jun 16 21:49:53 2003] [error] [client 203.175.237.100] no acceptable varian
    t: /usr/local/apache/htdocs/index.html
    [Mon Jun 16 21:49:56 2003] [error] [client 218.72.20.10] no acceptable variant:
    /usr/local/apache/htdocs/index.html
    [Mon Jun 16 21:49:56 2003] [error] [client 24.114.135.133] File does not exist:
    /usr/local/apache/htdocs/top/in.php
    [Mon Jun 16 21:49:57 2003] [error] [client 218.8.25.149] no acceptable variant:
    /usr/local/apache/htdocs/index.html
    [Mon Jun 16 21:49:59 2003] [error] [client 211.161.196.


    thakns

  8. #8
    Join Date
    Mar 2003
    Posts
    68
    any hint would be appreciated.

    [Mon Jun 16 21:52:41 2003] [warn] pid file /usr/local/apache/logs/httpd.pid over
    written -- Unclean shutdown of previous Apache run?
    [Mon Jun 16 21:52:42 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.2 mod_b
    wlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.14 OpenSSL/0.9.6b config
    ured -- resuming normal operations
    [Mon Jun 16 21:52:42 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/loca
    l/apache/bin/suexec)
    [Mon Jun 16 21:52:42 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Mon Jun 16 21:52:42 2003] [crit] (98)Address already in use: make_sock: could n
    ot bind to port 443
    [Mon Jun 16 21:52:42 2003] [error] [client 211.162.187.109] no acceptable varian
    t: /usr/local/apache/htdocs/index.html

  9. #9
    Join Date
    Jul 2001
    Posts
    889
    not sure about ssl mutex but the rest doesn't look too bad...

    be more specific about sites being "down."

    what can you get to
    what can't you get to
    what happens when u http? ssh? telnet? ftp?
    ping? etc.

    where exactly do you see these green lights? is it on the same server?

  10. #10
    Join Date
    Mar 2003
    Posts
    68
    the thing is HTTP is down every 8 hours or 10 hours. this is the log message I have seen.

    Do u know why it gets down ????

    thanks
    stephen

  11. #11
    Join Date
    Jul 2001
    Posts
    889
    Originally posted by mokkan
    the thing is HTTP is down every 8 hours or 10 hours. this is the log message I have seen.

    Do u know why it gets down ????

    thanks
    stephen
    you contradict yourself.

    All the status are green, but sites are down. Apache is up and all are up.
    see previous post. be more specific.

  12. #12
    Join Date
    Mar 2003
    Posts
    68
    I dont trust the gree n light , it updates every 10 minutes or so.

    My problem is apache get failure every 10 hours or so. This is what I can find in my log.


    Mon Jun 16 22:44:14 2003] [error] mod_ssl: Child could not open SSLMutex lockfi
    le /usr/local/apache/logs/ssl_mutex.18780 (System error follows)
    [Mon Jun 16 22:44:14 2003] [error] System: No such file or directory (errno: 2)
    [Mon Jun 16 22:44:14 2003] [error] mod_ssl: Child could not open SSLMutex lockfi
    le /usr/local/apache/logs/ssl_mutex.18780 (System error follows)
    [Mon Jun 16 22:44:14 2003] [error] System: No such file or directory (errno: 2)
    [Mon Jun 16 22:44:14 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.2 mod_b
    wlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.14 OpenSSL/0.9.6b config
    ured -- resuming normal operations
    [Mon Jun 16 22:44:14 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/loca
    l/apache/bin/suexec)
    [Mon Jun 16 22:44:14 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)


    any help would be appreciated.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •