Results 1 to 3 of 3
  1. #1

    XEN Centos 5.10 x86 Template Issue


    I recently migrated one of our nodes from one dc to another.

    How ever I lost the advanced.conf for SolusVM

    mount: could not find filesystem '/dev/root'
    Setting up other filesystems.
    Setting up new root fs
    setuproot: moving /dev failed: No such file or directory
    no fstab.sys, mounting internal defaults
    setuproot: error mounting /proc: No such file or directory
    setuproot: error mounting /sys: No such file or directory
    Switching to new root and running init.
    unmounting old /dev
    unmounting old /proc
    unmounting old /sys
    switchroot: mount failed: No such file or directory
    Kernel panic - not syncing: Attempted to kill init

    These are the current settings in advanced.conf I just cannot replicate how I fixed it last time. I did try extracting the Image to eee if it had a 32bit kernel but it has the same as the X86_64 Template.


  2. #2
    Join Date
    Jul 2010
    Do you set to use pygrub? From what I understand, centos 5 does not need xenpvos.

  3. #3
    Quote Originally Posted by Benny Kusman View Post
    Do you set to use pygrub? From what I understand, centos 5 does not need xenpvos.
    Using XenPVOS forces the VM to use SDA instead of XVDA that is where the problem is. But for some odd reason I did have it working by defining the 32bit template using .i386 or .i686 somewhere in the advanced.comf As I mentioned earlier it was working. But I lost the old Advanced.conf from another VPS node and now 8 or 9 VPS are offline and cannot boot.

    XEN is great but it can be a Pain.

Similar Threads

  1. need xen centos 6.2 64bit template for hypervm
    By Aiman H in forum Dedicated Server
    Replies: 5
    Last Post: 08-23-2012, 04:17 PM
  2. problem installing plesk on CentOS 6.2 x86-x64
    By VandaHost in forum Hosting Software and Control Panels
    Replies: 7
    Last Post: 04-25-2012, 11:42 PM
  3. Need short-term CentOS 6 x86 64 bit account
    By Nagle in forum Web Hosting
    Replies: 10
    Last Post: 03-20-2012, 05:40 PM
  4. centos-5-x86
    By ngedsch in forum Hosting Security and Technology
    Replies: 3
    Last Post: 11-15-2011, 09:22 AM
  5. Problem Installing Desktop On CentOs 5.4 x86 VPS
    By X-Dev in forum VPS Hosting
    Replies: 6
    Last Post: 08-19-2010, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts