I'm confused why this error still occur as I still have lots of spare servers left.

WARNING: [pool web2] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers)
Here's my php5-fpm settings:

pm.max_children = 256
pm.start_servers = 40
pm.min_spare_servers = 40
pm.max_spare_servers = 192
pm.max_requests = 500
Here's the results of smem -utk command:

User     Count     Swap      USS      PSS      RSS

web8        51        0   969.1M   999.5M     2.8G
web6        25        0     1.3G     1.3G     1.6G
web2       166        0     3.8G     3.8G     9.5G
root        59   390.3M     9.0G     9.1G     9.2G
           388   391.2M    17.0G    17.2G    26.2G
web2 max_spare_servers is set to 192 and smem reported 166 only (meaning I still have 26 left). So how come I still received the error above?

I don't think pm.start_servers and pm.min_spare_servers is the issue here unless I am mistaken.

I also enabled status of php-fpm and here's the results:

pool:                 web2
process manager:      dynamic
start time:           13/Jan/2014:19:22:03 +0800
start since:          78848
accepted conn:        165985
listen queue:         0
max listen queue:     0
listen queue len:     0
idle processes:       163
active processes:     3
total processes:      166
max active processes: 126
max children reached: 0
The idle processes is equal to 163. I thought that using dynamic as process manager will reclaim it's unused server to either start_servers or min_spare_servers.

Can anybody shade some light on me what's wrong on my configuration?