Results 1 to 21 of 21
  1. #1
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40

    Question WHMCS New Account Information Email Issue

    Hi,

    Our WHMCS Seems to be having an issue with our "New Account Information" email that is automatically sent to a client after an order is placed, and payment is received. The email is still the default "New Account Information" email template that comes with WHMCS...containing all the clients information for their new service. (Shared/Reseller)

    Basically the New Account Info. email is sending fine, however it is being marked as spam by Gmail/Hotmail - causing clients to not notice it as it does not reach their Inbox. We have all authentication steps in place, such as using SMTP, rDNS, SPF, DKIM etc. Therefore we believe that it is the email itself or WHMCS causing it to be marked as spam as NO other emails sent from WHMCS are marked as spam, only the New Account Information email is marked as spam.

    Does anybody have any suggestions on a potential fix to this issue? Already consulted with some people, had no luck.

    Any help is greatly appreciated.

    Thanks.
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  2. #2
    Join Date
    Apr 2002
    Location
    North Carolina
    Posts
    116
    If only the Welcome email is being sent to spam, it's the content of the email that's causing it. I do remember having this issue at one time, it was related to the wording used in the email.

  3. #3
    Join Date
    Dec 2010
    Location
    127.0.0.1
    Posts
    5,387
    It's just gmail, and a few others same thing on most billing systems, if clients mark them as spam, or if the content it the same as other emails it gets mistaken as spam.
    Licensecart - We only sell High Quality licenses
    Visit us @ Licensecart.com ~ sales(➾)licensecart.com ~ webhostbundle.com
    WHT isn't what it used to be… power changes people :]

  4. #4
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Thanks for the replies.

    Is there any specific content in the email causing this?

    Thanks.
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  5. #5
    Join Date
    Dec 2010
    Location
    127.0.0.1
    Posts
    5,387
    Quote Originally Posted by Shock_Hosting View Post
    Thanks for the replies.

    Is there any specific content in the email causing this?

    Thanks.
    Could be anything mate.
    Licensecart - We only sell High Quality licenses
    Visit us @ Licensecart.com ~ sales(➾)licensecart.com ~ webhostbundle.com
    WHT isn't what it used to be… power changes people :]

  6. #6
    Join Date
    Apr 2002
    Location
    North Carolina
    Posts
    116
    Does the email include any links where the link may have one address, while the text uses another address?

  7. #7
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Quote Originally Posted by CodeNSupport View Post
    Does the email include any links where the link may have one address, while the text uses another address?
    Do you mean the display of the links? Example: the link displays as google.com but really, when clicked goes to random.org? No, all links are matching - displayed the same.

    Thanks
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  8. #8
    Join Date
    Apr 2002
    Location
    North Carolina
    Posts
    116
    Yep. That is what I meant. I replied to your PM.

  9. #9
    Join Date
    Oct 2002
    Location
    State of Disbelief
    Posts
    22,951
    Quote Originally Posted by CodeNSupport View Post
    Yep. That is what I meant. I replied to your PM.
    Can't this be discussed in public where it will help others?
    Having problems, or maybe questions about WHT? Head over to the help desk!

  10. #10
    Join Date
    Apr 2002
    Location
    North Carolina
    Posts
    116
    I agree. But nothing helpful so far, or I would have updated the thread.

    The two possibilities we've talked about are the links in the email, which he changed to text, and sending through SMTP, rather than PHP mail.

    I've also seen suggestions to make sure the site is on a dedicated IP, so it isn't sending from an IP address that could be sending spam.
    Last edited by EStarr; 01-06-2014 at 07:53 PM. Reason: another idea

  11. #11
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Is anyone else experiencing this issue? We believe it is the Email Content...
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  12. #12
    Join Date
    Dec 2011
    Location
    Montreal
    Posts
    334
    Quote Originally Posted by Shock_Hosting View Post
    Is anyone else experiencing this issue? We believe it is the Email Content...
    Try to turn off cloudfare and test again. When you have CloudFlare, reverse DNS doesn't match the forward DNS. Please check on this. Most of the servers are checking this against spam.

    Regards
    ROWEBCA
    Server Services

  13. #13
    What wording did you add and/or change, if any?

  14. #14
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Quote Originally Posted by Rowebca View Post
    Try to turn off cloudfare and test again. When you have CloudFlare, reverse DNS doesn't match the forward DNS. Please check on this. Most of the servers are checking this against spam.

    Regards
    Ill try this and let you know, this may by why also... it is only the New Account Information email being sent as spam though, all the other emails are fine - not sure if it is due to CloudFlare then.
    Thanks

    Quote Originally Posted by Onra Host View Post
    What wording did you add and/or change, if any?
    We havent changed any wording, its still the default New Account Information Template.
    Last edited by Shock Hosting; 01-07-2014 at 01:02 PM.
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  15. #15
    Join Date
    Dec 2011
    Location
    Montreal
    Posts
    334
    Quote Originally Posted by Shock_Hosting View Post
    It is only the New Account Information email being sent as spam though, all the other emails are fine - not sure if it is due to CloudFlare then.
    Thanks
    Yes, you're right, I didn't see that all others emails are working.
    Can you post the full header of the email, from the provider where your email is arrive in spam box? Only if is not a problem for you, and try to hide the ip etc.


    Regards
    ROWEBCA
    Server Services

  16. #16
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40

    *

    Quote Originally Posted by Rowebca View Post
    Yes, you're right, I didn't see that all others emails are working.
    Can you post the full header of the email, from the provider where your email is arrive in spam box? Only if is not a problem for you, and try to hide the ip etc.


    Regards
    Here is the header: http://pastebin.com/GHEz6kZR

    Thanks
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  17. #17
    Have you double checked your server IP and domain against blacklisting's? Gmail have some internal checking, and it may be tricky to make it actually come in inbox each time.
    BeltHosting.com Staff. Shared Web Hosting | Reseller Web Hosting | IRCD Hosting | psyBNC/sBNC/eggdrop/znc Hosting
    xShellz Linux Shell & IRCD Hosting.
    24/7 Live & Ticket Support

  18. #18
    Join Date
    Dec 2011
    Location
    Montreal
    Posts
    334
    Quote Originally Posted by Shock_Hosting View Post
    Here is the header: http://pastebin.com/GHEz6kZR

    Thanks
    Another question, for the email that is working are you using php (mail) or smtp ? Can be a problem with hostname difference and reverse dns.


    From this line:

    Received: from shockhosting.net ([2#8.115.202.###])

    You remove what was before IP or was just this?

    It should be:

    Received: from hostname.shockhosting.net (hostname.shockhosting.net. [2#8.115.202.###])



    The ip "2#8.115.202.###" is not blacklisted so is not that the problem.


    Edit: I see that your server hostname is different than reverse DNS record !!!

    Regards
    Last edited by rowebca; 01-07-2014 at 03:10 PM.
    ROWEBCA
    Server Services

  19. #19
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Still recieving this issue.Even recieving the issue when using Amazon SES. (SMTP Service)

    Thanks
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

  20. #20
    Join Date
    Jun 2011
    Posts
    2,286
    I ended up ditching CloudFlare as it was causing more problems that it's worth. It breaks a number of WHMCS features. For example, pre-defined replies don't get proper formatting with the Auto Minify setting in CloudFlare enabled. Plus CF have been having a number of outages over the past few months (more than one would like) which utlimately take sites down.

    I did have major problems with email getting delivered to spam last month but sat down and spent some time fine tuning the mail server with DKIM, SPF, rDNS, etc. That combined with no blacklistings + a good IP reputation has been fine. What is the reputation from a SenderBase lookup?

    Not really sure what to suggest.

  21. #21
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    40
    Quote Originally Posted by Ethernet Servers View Post
    I ended up ditching CloudFlare as it was causing more problems that it's worth. It breaks a number of WHMCS features. For example, pre-defined replies don't get proper formatting with the Auto Minify setting in CloudFlare enabled. Plus CF have been having a number of outages over the past few months (more than one would like) which utlimately take sites down.

    I did have major problems with email getting delivered to spam last month but sat down and spent some time fine tuning the mail server with DKIM, SPF, rDNS, etc. That combined with no blacklistings + a good IP reputation has been fine. What is the reputation from a SenderBase lookup?

    Not really sure what to suggest.
    We no longer use CloudFlare and we have also "fine tuned" our mail server as you said. I dont think its the server though, as all emails send fine - right to the inbox - but its just the new account information email sent by WHMCS that goes to spam. Its only 1 automated email that is having the issues.

    Thanks
    Shock Hosting | High quality hosting at an affordable price!
    LiteSpeed | CloudLinux | Softaculous | NYC Metro Location

Similar Threads

  1. WHMCS New account information email not showing correctly!
    By robbstech in forum Hosting Software and Control Panels
    Replies: 6
    Last Post: 04-11-2013, 07:07 PM
  2. Dedicated IP for cpanel account and forwarded email issue
    By rankris in forum Hosting Security and Technology
    Replies: 4
    Last Post: 09-28-2011, 10:18 AM
  3. Critical WHMCS issue, client account wiped out without any reason!!
    By kandyjet in forum Hosting Software and Control Panels
    Replies: 13
    Last Post: 07-26-2011, 09:40 AM
  4. WHMCS Create Hosting Account issue
    By Arena Hosts in forum Hosting Software and Control Panels
    Replies: 11
    Last Post: 01-20-2010, 12:50 PM
  5. Deleting an email account in cPanel/WHMCS
    By funlog in forum Hosting Software and Control Panels
    Replies: 10
    Last Post: 01-03-2010, 12:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •