Results 1 to 5 of 5

Thread: Php Conflict

  1. #1
    Join Date
    Mar 2013
    Posts
    270

    Php Conflict

    Hi,

    I'm using centos 6.4. So i want to install php 5.4.23. It conflict with 5.3. I didn't yet install 5.3
    Code:
    Transaction Check Error:
      file /etc/php.ini from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/curl.so from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/fileinfo.so from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/json.so from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/phar.so from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/zip.so from install of php54-common-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-common-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/gd.so from install of php54-gd-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-gd-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/pdo.so from install of php54-pdo-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/pdo_sqlite.so from install of php54-pdo-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/sqlite3.so from install of php54-pdo-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-pdo-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/mysql.so from install of php54-mysql-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-mysql-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/mysqli.so from install of php54-mysql-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-mysql-5.3.3-27.el6_5.x86_64
      file /usr/lib64/php/modules/pdo_mysql.so from install of php54-mysql-5.4.23-3.ius.el6.x86_64 conflicts with file from package php-mysql-5.3.3-27.el6_5.x86_64
    
    Error Summary
    -------------
    How to fix this issue?

    Thanks.

  2. #2
    Join Date
    Nov 2003
    Location
    Texas, United States
    Posts
    114
    Best bet is to custom compile one of them, giving it a different installation directory using the "configure" options. You can download the source code from PHP's web site (www.php.net).
    Tim Benoit

  3. #3
    Join Date
    Dec 2007
    Location
    LocalHost
    Posts
    1,303
    Is PHP 5.3 already installed on your server??
    Try un-installing PHP 5.3 first
    Code:
    yum remove php php-mysql
    yum clean all
    YagHost - Pure SSD Hosting | Since 2007 | Average Response Time: 15 min
    Web Hosting | Reseller Hosting | Managed VPS Hosting
    99.9% Server Uptime Guarantee | 24/7 Rapid Response Tech Support | 30 Day Money Back Guarantee
    LopHost.com - Web Hosting Tutorials

  4. #4
    Join Date
    Nov 2003
    Location
    Texas, United States
    Posts
    114
    Good point. I went forward thinking the OP wanted both versions installed.
    Tim Benoit

  5. #5
    Join Date
    May 2013
    Location
    India
    Posts
    748
    You have PHP 5.3 already installed on the server ( can be loaded along with OS install if we select the specific packages ). Run rpm -qa | grep php and that will list all the related PHP packages installed on your server. Then remove all the PHP related packages ( that includes php, php-common, php-mysql, php-pdo, php-gd, etc )and then install PHP 5.4; that will fix the issue.

Similar Threads

  1. PHP conflict between 2 tags?!
    By NexD in forum Programming Discussion
    Replies: 2
    Last Post: 07-07-2012, 04:40 PM
  2. Conflict
    By Sting13 in forum Computers and Peripherals
    Replies: 2
    Last Post: 11-08-2007, 03:34 PM
  3. Conflict?
    By Captain Canuck in forum Hosting Security and Technology
    Replies: 2
    Last Post: 03-26-2007, 06:58 PM
  4. PHP and Textbox Conflict !!!
    By Pc-Center.gr in forum Programming Discussion
    Replies: 22
    Last Post: 06-19-2005, 12:30 AM
  5. PHP and JavaScript Conflict
    By Pete Bekisz in forum Programming Discussion
    Replies: 2
    Last Post: 05-15-2004, 08:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •