Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2013

    PHP.ini file errors when uploading

    See the video above.

    I am using plesk control panel and i have setted the values in /etc to php.ini to this,

    ; Resource Limits ;
    ; Maximum execution time of each script, in seconds
    max_execution_time = 0
    ; Maximum amount of time each script may spend parsing request data. It's a good
    ; idea to limit this time on productions servers in order to eliminate unexpectedly
    ; long running scripts. 
    ; Default Value: -1 (Unlimited)
    ; Development Value: 60 (60 seconds)
    ; Production Value: 60 (60 seconds)
    max_input_time = -1
    ; Maximum input variable nesting level
    ;max_input_nesting_level = 64
    ; Maximum amount of memory a script may consume (128MB)
    memory_limit = -1
    ; File Uploads ;
    ; Whether to allow HTTP file uploads.
    file_uploads = on
    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ;upload_tmp_dir = /var/www/vhosts/
    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 0M
    I have a forum + file hosting site. I want to get my values unlimited. Not actually unlimited but I want my users to be able to upload files till 1GB.

    Currently , i can upload files less than 200 MB, and more than that gives me the progress bar rstarting. I am sure there is nothing wrong witht he scripts uploading as both forum and file sharing script do the same work.

    Is there some values that i am missing ?
    I wanna be able to upload big files :3
      0 Not allowed!

  2. #2
    Join Date
    Sep 2013
    and i just realised a thing, after the above edit in PHP config, i couldn't actually enter my wordpress logins site hosted in that server :O
      0 Not allowed!

  3. #3
    Join Date
    Sep 2013

    Please any help

    Hey, guys anyhelp ?

    here is my php settings,
      0 Not allowed!

  4. #4
    Join Date
    Sep 2013

    Re question

    Here is something which is more clear + says what i have done till now,

    I have xenforo and yetishare. In both, when i try to upload files around 256 mb, the progrss bar starts, goes till 150mb + and then the progess bar again comes back to 0% and start uploading again. It does like 4 times then shows error that the file can't be uploaded.

    I can upload a file, 126mb without any problem.

    My Php Info :

    I have set them temp directory of php to /tmp and uploaded a .htaccess file there with this settings, [these are the only lines in it]

    LimitRequestBody 0
    php_value upload_max_filesize 0
    php_value post_max_size 4939212390
    My file uploader, is index.php, and the .htaccess file also has the above settings as well as the folder which the files are saved also have the above settings.

    You could see my php.ini settings, link i gave above.

    IN httpd.conf under my httpd folder in /etc i have set timeout to 900.

    I couldn't find limit request body anywhere.

    In php.conf, i have added this to the last section,

    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    LimitRequestBody 0
    and i have added this line to fcgid.conf,

    FcgidMaxRequestLen 1073741824
    so it looks like,

    # This is the Apache server configuration file for providing FastCGI support
    # via mod_fcgid
    # Documentation is available at

    LoadModule fcgid_module modules/

    <IfModule mod_fcgid.c>

    <IfModule !mod_fastcgi.c>
    AddHandler fcgid-script fcg fcgi fpl

    FcgidIPCDir /var/run/mod_fcgid/sock
    FcgidProcessTableFile /var/run/mod_fcgid/fcgid_shm

    FcgidIdleTimeout 40
    FcgidProcessLifeTime 30
    FcgidMaxProcesses 20
    FcgidMaxProcessesPerClass 8
    FcgidMinProcessesPerClass 0
    FcgidConnectTimeout 30
    FcgidIOTimeout 45000
    FcgidInitialEnv RAILS_ENV production
    FcgidIdleScanInterval 10
    FcgidMaxRequestLen 1073741824

    i have also added edited it, in domain configuration, nginxdomainvirtualhost.php.

    Rebooted servers, reloaded httpd, restarted https, reconfigured things, but still it is just as same as before:/

    I want to be able to upload 1gb-2gb files in my forum.

    I can pay less than 10$ to anyone who could remotely connect and try to help me

    here is the example of it uploading, Please see the link below to see it uploading.

    this is the one i followed :

    Edit--- please guys, i am just 14, if you could help me <<snipped>>
    Last edited by Postbox; 12-22-2013 at 08:38 AM.
      0 Not allowed!

Similar Threads

  1. Need help [php.ini] Logging all php errors
    By hbhb in forum Hosting Security and Technology
    Replies: 23
    Last Post: 09-03-2008, 03:28 AM
  2. Session errors - php.ini related
    By optimumd in forum Hosting Security and Technology
    Replies: 3
    Last Post: 08-20-2007, 02:50 AM
  3. php.ini file :(
    By reza777 in forum Hosting Security and Technology
    Replies: 5
    Last Post: 06-15-2006, 02:35 PM
  4. Questions(Uploading,php.ini,and more)
    By Embrance in forum Hosting Security and Technology
    Replies: 4
    Last Post: 03-13-2006, 02:24 PM
  5. help with php.ini file
    By tbk49 in forum Reseller Hosting
    Replies: 3
    Last Post: 11-24-2003, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts