Results 1 to 8 of 8
  1. #1
    Join Date
    Dec 2013
    Location
    Hyderabad
    Posts
    55

    504 Gateway Time-out using Nginx on vps

    now iam getting 504 Gateway Time-out using Nginx on vps server when i am running .php script may be it execute in 4-5 minutes

    and my php configuration in whm

    Home
    Service Configuration
    PHP Configuration Editor
    memory limit 64 mb
    max_execution_time 3600
    max_input_time 60

    just changed max input time 60 to 3600

    also opened a ticket with support but they respond with in hours

    their resolution time 2-3 hours
    if i want support with in 10 minutes standard fees apply

    any way my i am hosting interserver .net

  2. #2
    Join Date
    May 2013
    Location
    India
    Posts
    748
    Likely it cannot communicate with PHP. How is PHP is configured on your server? If it is php-fpm, make sure the service is running and it is properly configured. Or if it is legacy fcgi method, make sure it is properly configured.

  3. #3
    Join Date
    Dec 2013
    Location
    Hyderabad
    Posts
    55
    i am still newbie to vps and .php how can i check that using whm or putty

    my support disabled ngnix and the default Apache running now

  4. #4
    Join Date
    May 2013
    Location
    India
    Posts
    748
    If you are using any plugin for nginx support on your cPanel server, reinstall the plugin and see how it goes. Else contact the plugin developers to report the issue. Without checking the exact cause, I don't know how to give you troubleshooting steps as such plugins works with custom code.

  5. #5
    Join Date
    Dec 2013
    Location
    Hyderabad
    Posts
    55
    my host support uninstalled ngnix and server running Apache now i am getting all db connection error mysql server using high cpu usages

  6. #6
    what is your VPS specs?
    HalfDedi.com Half Dedicated Half Price
    We provide affordable VPS hosting solution Singapore datacenter

  7. #7
    Join Date
    Oct 2010
    Location
    Cochin
    Posts
    7
    Hi,

    As mentioned in the previous post. The problem might be related with php-fpm. I believe that your support staffs checked the service before the removal.

  8. #8
    Join Date
    Jan 2003
    Posts
    32
    By default, when using FastCGI with NGINX (which is how PHP-FPM communicates with NGINX), NGINX has a default 60 second timeout. This means that after 1 minute, if your PHP script hasn't sent any data back, NGINX will stop listening and give you a 504 gateway timeout - regardless of how PHP is set up. That setting can be changed in your nginx configuration with the directive fastcgi_read_timeout. Not knowing your full environment I can't tell you where exactly your fastcgi parameters are being housed, but they are most likely in a configuration file under /etc/nginx/ - possibly /etc/nginx/conf.d/ or maybe right in /etc/nginx/nginx.conf. Those are just my off the cuff guesses for file locations though, as I do not use cpanel and don't know your full environment.

Similar Threads

  1. Nginx 504 error
    By jamiedolan in forum Web Hosting
    Replies: 0
    Last Post: 03-16-2011, 09:54 PM
  2. 504 Gateway Timed Out Error
    By ransome in forum Hosting Security and Technology
    Replies: 4
    Last Post: 01-08-2011, 04:19 PM
  3. Nginx - 504 Timeout
    By Ixape in forum VPS Hosting
    Replies: 0
    Last Post: 11-28-2010, 01:56 PM
  4. 504 Gateway Timeout
    By papaj in forum Hosting Security and Technology
    Replies: 0
    Last Post: 12-19-2003, 02:14 AM
  5. 504 Gateway Error?
    By smidwap in forum Web Hosting
    Replies: 2
    Last Post: 10-21-2002, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •