Results 1 to 4 of 4
  1. #1

    problems with jailshell not disabling...

    My host is not able to figure out why jailshell keep showing up in emails that it can not find shell commands like mail.

    They have disabled jailshell for all domains under my reseller account with them. But all of my own sites that use cron job to backup certain databases do not run fully due to cron job not being able to find mail command.

    I have created a dummy cron job to send just an email to myself every few minutes, and the cron job runs, but no email is received as it can not find or use mail command.

    My host first disabled jailshell when the problem first happened and the emails came in ok, but as I had the cron job setup to email every few minutes to test it worked without having to wait for 24 hours to see if it worked, this change back to every 24 hours meant that the problem came back due to me changing it.

    All other cron job work fine as I do not think it is a cron job not working, just that it seems to alter something on the server to make is go back to using the jailshell method even thought it should be disabled for that account or all accounts.

    Has anyone had this happen and was able to fix it and how?

    Or can anyone suggest what I or they can do next to fix this. As this has been going on for months. They have even reinstalled parts and the whole server again once before but still the problems comes back.

    I am wondering if there is a problem with whm or cpanel itself that is causing the issues to return when cron job is created or edited?

    Anyone got any thoughts ?

    CLOUDLINUX 6.5 x86_64 standard – svr128
    WHM 11.40.0 (build 29)
    Last edited by jasonc310771; 12-17-2013 at 10:04 AM. Reason: added server versions

  2. #2
    Join Date
    May 2013
    From cPanel 11.38, cron jobs run in Jailed shell ( ). Perhaps modifying SHELL variable may help for you; not sure whether cPanel will overwrite it with any updates. Or ask your host to enable mail command to the jail shell and that will help.

  3. #3
    Join Date
    Oct 2010
    You say they are using Cloud Linux. Then the issue won't be jailshell, but whether they've allowed the mail command into CageFS.

    Their docs are here:

    If it's not there, they need to create a new file in /etc/cagefs/conf.d with a link to the mail executable. Then run /usr/sbin/cagefsctl --force-update

    Interested in which hosts I'd recommend? Unmanaged VPS Reviews | Managed VPS Reviews

  4. #4
    Join Date
    May 2013
    mail command is the part of default CageFS skeleton I believe. Anyway thanks for pointing out that possibility.

Similar Threads

  1. Jailshell or noshell?
    By 0nijin in forum Hosting Security and Technology
    Replies: 4
    Last Post: 08-10-2009, 12:25 AM
  2. Disabling NAMED now=problems
    By BmXStuD in forum Hosting Security and Technology
    Replies: 13
    Last Post: 08-27-2006, 01:02 PM
  3. jailshell, where do I get it?
    By bubazoo in forum Hosting Software and Control Panels
    Replies: 7
    Last Post: 01-31-2005, 07:46 PM
  4. jailshell question
    By thunderace in forum Hosting Security and Technology
    Replies: 2
    Last Post: 10-04-2004, 07:40 PM
  5. cPanel jailshell problems
    By [zev] in forum Hosting Software and Control Panels
    Replies: 6
    Last Post: 09-27-2004, 04:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts