Results 1 to 4 of 4
  1. #1

    VSFTP: 550 Error when trying upload to a second drive

    Hello all, I have added a new hard drive to my server which is mounted as /newdrive

    I have added a new user with home dir /newdrive/newuser

    I can add new folders and files to this home dir with ssh in the sever with this new user account.

    When I tried to upload via ftp, it returned 550 and 553 error when I create new dir / upload files using this new account.

    There is no such problem when I ftp into older accounts in the server with home dir /home/$users

    I have tried to google for the answer but I cannot really find the answer.

    Is there any folks here who know what the problem is?

    Thanks in advance!!

  2. #2
    Join Date
    Dec 2013
    Sydney, Australia
    Can you verify your FTP Server installation has no upload restrictions?

    Are you logging into the FTP Server as a user that has the correct permissions to upload to that directory?

    Maybe check the permissions of wherever you're uploading files to that it works, and mimic these permissions on the directory where it does not work.

  3. #3
    Thanks for the reply. Eventually I have find out what the problem is. It is selinux. I just set ftp_home_dir to on and I did not realize that ftp will not work if the home dir is not in /home. So I set allow_ftpd_full_access to on and it is working now.

  4. #4
    Join Date
    Dec 2013
    Sydney, Australia
    Good to hear you got everything working then.

    SELinux is both wonderful and inconvenient (sometimes), I really do need to learn how to use it properly.

Similar Threads

  1. SMTP 550 error?
    By Melting-Dog in forum Web Hosting
    Replies: 4
    Last Post: 07-23-2012, 01:03 PM
  2. 550 - no such user error
    By expatCanuck in forum Hosting Software and Control Panels
    Replies: 4
    Last Post: 10-25-2011, 06:35 AM
  3. QMAIL 550 Error
    By boonchuan in forum Hosting Security and Technology
    Replies: 1
    Last Post: 04-19-2004, 04:04 PM
  4. vsftp resume upload
    By maxbear in forum Hosting Security and Technology
    Replies: 0
    Last Post: 12-09-2003, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts