Results 1 to 5 of 5
  1. #1

    * Unable to re-install grub in centos 6.4

    Hi All,
    I recently download centos 6.4 minimal 1386 from and installed it on my old Pentium4 32 bit machine at home. It has got one 80gb HDD and splited into 3 partitions. Two of them are ntfs filesystem consist of Windows XP present in them since long before. I made the third partition to ext4 and installed centos 6.4 in it. One day the XP went crashed and I had to reinstalled it for my parents. But then the trouble started, I lost the Dual Boot Selection at the machine startup.
    I thought I would probably need to reinstall the grub of centos. So I put the same installation cd "CentOS-6.4-i386-minimal" into CD Drive which was used to install the centos and chose the "Rescue Mode".

    Reference urls that google gave me:

    Steps I followed up:
    - Selected “Rescue installed system”.
    - Selected “Local CD\DVD” for the Rescue Method.
    - On the “Rescue Screen”, selected "Continue".
    - On the “First Aid Kit quickstart menu”, selected “shell Start shell”.
    - I got the shell as "bash-4.1#" successfully.
    - Then I tried to run “chroot /mnt/sysimage” and hit with the following error.

    bash-4.1# chroot /mnt/sysimage
    chroot: failed to run command '/bin/sh' : No such file or directory

    How can I solve this error?. Can anyone please help me on this?
    I am attaching the screenshot of exact error message and fdisk result with this post

    /dev/sda5 is the boot partition
    /dev/sda6 is the '/' partition
    Last edited by redhat_boy; 11-25-2013 at 12:15 AM.

  2. #2
    looks like you don't have your original fs mounted in /mnt/sysimage, so there is nothing in that directory to chroot.

    ls -la /mnt/sysimage
    df -h
    fdisk -l
    Last edited by DarkVoodoo; 11-25-2013 at 05:46 AM.

  3. #3
    Boot system in rescue mode and paste the results of df -h and fdisk -l here so we can throw some light on it

  4. #4
    Thanks guys for your time, I fixed it myself. "/" and "boot" partitions were not properly mounting under /mnt/sysimage. Finally I had to do it manually and chroot worked fine. Also reinstalled grub

  5. #5
    You can check the complete procedure in my blog

Similar Threads

  1. centos stuck in grub
    By microz in forum Dedicated Server
    Replies: 6
    Last Post: 05-05-2013, 11:09 PM
  2. Centos grub problem
    By mixmox in forum Hosting Security and Technology
    Replies: 13
    Last Post: 11-16-2012, 09:43 AM
  3. Centos stuck on grub, keyboard unusable
    By ishan in forum Dedicated Server
    Replies: 9
    Last Post: 12-11-2011, 05:57 PM
  4. Centos grub.conf not found !?
    By goolex in forum Hosting Security and Technology
    Replies: 8
    Last Post: 02-10-2010, 01:36 AM
  5. Grub on Centos
    By gbjbaanb in forum Hosting Security and Technology
    Replies: 4
    Last Post: 08-13-2006, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts