Results 1 to 21 of 21
  1. #1
    Join Date
    Jul 2007
    Posts
    273

    requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the webs

    Hi guys, i get this error messages using some scripts

    Site error: the file /home/username/public_html/filename.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.
    - i am using php 5.2.x

    - in whm > PHP Configuration Editor > Advanced > zend_extension, already insert this :
    /usr/local/IonCube/ioncube_loader_lin_5.2.so

    - in whm > Tweak settings > cPanel PHP loader
    i try checklisted ioncube only, its still same
    i try checklisted ioncube & zend, its still same
    i try checklisted ioncube, zend & sourceguardian, its still same


    what could still be wrong, please help
    Lets be stable diligent person

  2. #2
    Do you have a php.ini file in your account? Try to disable it and see if you're still seeing the error.
    Visiba | UK and US based cPanel Web Hosting
    Softaculous Script Installer | Daily Backups | SEO Tools | SSD Servers
    99.9% Uptime Guarantee | 30 Days Money Back Guarantee | 24x7 Support

  3. #3
    Join Date
    Jul 2007
    Posts
    273
    Quote Originally Posted by Visiba View Post
    Do you have a php.ini file in your account? Try to disable it and see if you're still seeing the error.
    which php.ini do you mean? i am using vps & have root access/whm
    Lets be stable diligent person

  4. #4
    I mean here:

    /home/username/public_html

    In case you have a php.ini file there, it will overwrite the settings from your global VPS php.ini file. You must include the path to IonCube in the php.ini file (if you have one there).
    Visiba | UK and US based cPanel Web Hosting
    Softaculous Script Installer | Daily Backups | SEO Tools | SSD Servers
    99.9% Uptime Guarantee | 30 Days Money Back Guarantee | 24x7 Support

  5. #5
    Join Date
    Feb 2013
    Posts
    351

    Re: requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the

    Are you running suphp? If so your local one should do it, if not ssh into your server and do php-i | grep php.ini
    North Hosts Limited - Company Number 8808995 Affordable UK Web Hosting
    █ Shared Reseller VPS Dedicated 24/7/365 Support Instant Activation
    █ Trendy Site Builder CloudFlare Softaculous Seo Tools cPanel

  6. #6
    Join Date
    Jul 2007
    Posts
    273
    yes it is suphp

    i already tried create local php.ini with this content

    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so";
    and put it inside public_html

    its working for a site, but it is better if i can make it working for the entire server






    i checked there is already this lines in php.ini in /usr/local/lib/ and /usr/lib/

    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"
    but why its still not working for another site, is it really need local php.ini for suphp?
    Lets be stable diligent person

  7. #7
    Join Date
    Feb 2013
    Posts
    351

    Re: requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the

    If you want to make it work for the general server just locate your php.ini via the command I gave and edit that? Obviously any sites that you have with local php.ini will read those first.
    North Hosts Limited - Company Number 8808995 Affordable UK Web Hosting
    █ Shared Reseller VPS Dedicated 24/7/365 Support Instant Activation
    █ Trendy Site Builder CloudFlare Softaculous Seo Tools cPanel

  8. #8
    Join Date
    Jul 2007
    Posts
    273
    already tried the ssh command

    but i only get this, how is it?

    [email protected] [/usr/lib]# php-i | grep php.ini
    -bash: php-i: command not found
    Lets be stable diligent person

  9. #9
    Join Date
    Feb 2013
    Posts
    351

    Re: requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the

    If your not sure if your editing the correct file simply create a php file with <?php*phpinfo();*?>
    as the contents and upload to a site that isnt using a local php.ini file, that will tell you where its pulling the config from.
    North Hosts Limited - Company Number 8808995 Affordable UK Web Hosting
    █ Shared Reseller VPS Dedicated 24/7/365 Support Instant Activation
    █ Trendy Site Builder CloudFlare Softaculous Seo Tools cPanel

  10. #10
    Join Date
    Jul 2007
    Posts
    273
    Quote Originally Posted by NorthHosts View Post
    If your not sure if your editing the correct file simply create a php file with <?php*phpinfo();*?>
    as the contents and upload to a site that isnt using a local php.ini file, that will tell you where its pulling the config from.
    i checked its like this

    Configuration File (php.ini) Path /usr/lib
    Loaded Configuration File /usr/local/lib/php.ini
    so the php.ini is in /usr/lib and /usr/local/lib right?


    this lines already there since before
    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"






    already tried change the lines to be like this, but still no change, any other way that i can try?

    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"

    [Zend]
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"
    Lets be stable diligent person

  11. #11
    Join Date
    Nov 2006
    Posts
    648
    Quote Originally Posted by basketmen View Post
    - in whm > Tweak settings > cPanel PHP loader
    i try checklisted ioncube only, its still same
    i try checklisted ioncube & zend, its still same
    i try checklisted ioncube, zend & sourceguardian, its still same


    what could still be wrong, please help
    That's only for the cPanel/system PHP - you should recompile using EasyApache, and tick ioncube loader box, then it should work on sites you host on the server, that's the most foolproof way of doing it anyway.
    Twikam
    UK cPanel hosting Super fast UK shared hosting with IP's and SSL
    UK VPS Hosting High Bandwidth VPS Servers

  12. #12
    Join Date
    Jul 2007
    Posts
    273
    Quote Originally Posted by twikamltd View Post
    That's only for the cPanel/system PHP - you should recompile using EasyApache, and tick ioncube loader box, then it should work on sites you host on the server, that's the most foolproof way of doing it anyway.
    yes already installed it in easyapache before

    its working for local php.ini under public_html, but still not working for the entire server, there might be still wrong settings
    Lets be stable diligent person

  13. #13
    Join Date
    Apr 2007
    Location
    US, UK, Europe, ME
    Posts
    258
    What's the output when you just execute "php -v" ? This can be also the result of having duplicate entries for this extension.

    "cat /usr/local/lib/php.ini|grep ioncube" and check if you have it listed more than once.

  14. #14
    Join Date
    Dec 2011
    Location
    Montreal
    Posts
    334
    Quote Originally Posted by basketmen View Post
    already tried the ssh command

    but i only get this, how is it?


    [email protected] [/usr/lib]# php-i | grep php.ini
    -bash: php-i: command not found
    Make a space between php and -i like:

    Code:
    [email protected] [/opt]# php -i | grep php.ini
    Configuration File (php.ini) Path => /pat/to/php.ini
    Loaded Configuration File => /path/to/loaded/php.ini

    ...and please check for others php.ini (maybe you have inside your cpanel account, home/username folder). You can create a file info.php inside /home/username/public_html/ of that account and add:
    Code:
    <?php
    phpinfo();
    ?>
    and look at the loaded configuration (php.ini) where you have to check, modify to fit your requirements.


    Regards
    Last edited by rowebca; 11-02-2013 at 11:37 AM.
    ROWEBCA
    Server Services

  15. #15
    Join Date
    Jul 2007
    Posts
    273
    php -v
    the result is
    [email protected] [~]# php -v
    PHP 5.2.17 (cli) (built: Jul 3 2013 08:12:40)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.4.1, Copyright (c) 2002-2013, by ionCube Ltd.







    cat /usr/local/lib/php.ini|grep ioncube
    the result is
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"










    php -i | grep php.ini
    the result is
    [email protected] [~]# php -i | grep php.ini
    Configuration File (php.ini) Path => /usr/local/lib
    Loaded Configuration File => /usr/local/lib/php.ini





    and please check for others php.ini (maybe you have inside your cpanel account, home/username folder)
    the result from phpinfo is
    Configuration File (php.ini) Path /usr/lib
    Loaded Configuration File /usr/local/lib/php.ini




    any guess guys?
    Lets be stable diligent person

  16. #16
    Join Date
    Nov 2011
    Location
    Datacenters
    Posts
    1,313
    1.Compile Easy-apache and add ion-cubeloader if not .

    2.Try this command and let me know the status :

    Code:
    /scripts/phpextensionmgr install IonCubeLoader
    Fastest . Reliable . Affordable Web Hosting by MNCHOST.COM

    █ Shared | Business | Reseller : 1.Litespeed 2.Cpanel 3.Pure SSDs 4.US Support 5.Hourly Backups
    Fully Managed Dedicated Servers | Premium Bandwidth | New SSD-US Servers

  17. #17
    Join Date
    Feb 2013
    Posts
    351

    Re: requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the

    Are you editing that file??
    North Hosts Limited - Company Number 8808995 Affordable UK Web Hosting
    █ Shared Reseller VPS Dedicated 24/7/365 Support Instant Activation
    █ Trendy Site Builder CloudFlare Softaculous Seo Tools cPanel

  18. #18
    Join Date
    Jul 2007
    Posts
    273
    Quote Originally Posted by MNCHOST - Chris View Post
    1.Compile Easy-apache and add ion-cubeloader if not .

    2.Try this command and let me know the status :

    Code:
    /scripts/phpextensionmgr install IonCubeLoader
    1. yes it is already installed using easyapache before
    http://freakimage.com/images/940ionc...alled_befo.jpg


    2. ok here it is

    [email protected] [~]# /scripts/phpextensionmgr install IonCubeLoader
    Updating md5sum list
    Fetching http://httpupdate.cpanel.net/cpanelsync/easy/targz.yaml (connected:0).......(request attempt 1/12)...Using dns cache file /root/.HttpRequest/httpupdate.cpanel.net......searching for mirrors (mirror search attempt 1/3)......loaded mirror speeds from cache......mirror search success......connecting to 67.222.0.10...@67.222.0.10......connected......receiving...100%......request success......Done
    Installing IonCubeLoader
    Determining PHP version
    Installing IonCube Loader binaries
    Activating IonCube Loader extension in /usr/local/lib/php.ini
    IonCube Loader extension activated
    how is it? i try open the site, still same
    Lets be stable diligent person

  19. #19
    Join Date
    Jul 2007
    Posts
    273
    Quote Originally Posted by NorthHosts View Post
    Are you editing that file??
    do you mean this one? :

    already tried change the /usr/local/lib/php.ini lines to be like this, but still no change, any other way that i can try?

    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"

    [Zend]
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"

    its ok, i already revert it with the backup file, no problem with this
    Lets be stable diligent person

  20. #20
    Join Date
    Nov 2011
    Location
    Datacenters
    Posts
    1,313
    hi Basketman ,

    Thanks for follow my instruction .I would like to go in depth in this issue and request you to check below command and let me know the output while browsing same url :

    Code:
    tail -f /usr/local/apache/logs/error_log | grep 'cpanelaccountname'
    Or

    Code:
    tail -f /usr/local/apache/logs/error_log | grep 'www.yourwebsitelink.com'
    Fastest . Reliable . Affordable Web Hosting by MNCHOST.COM

    █ Shared | Business | Reseller : 1.Litespeed 2.Cpanel 3.Pure SSDs 4.US Support 5.Hourly Backups
    Fully Managed Dedicated Servers | Premium Bandwidth | New SSD-US Servers

  21. #21
    It is better to contact your hosting provider, they will do it for you.

Similar Threads

  1. the ionCube PHP Loader vs Zend Optimizer
    By virtual memory in forum Hosting Software and Control Panels
    Replies: 4
    Last Post: 03-30-2011, 02:44 AM
  2. Erro with ionCube PHP Loader ioncube_loader_lin_5.2
    By saeed25 in forum VPS Hosting
    Replies: 17
    Last Post: 01-10-2011, 11:08 AM
  3. ionCube PHP Loader ioncube_loader_lin_5.2.so
    By jestin_virtual in forum Hosting Security and Technology
    Replies: 2
    Last Post: 10-15-2009, 08:08 AM
  4. How to setup in 64bit ionCube PHP Loader?
    By ASTRAPI in forum Hosting Software and Control Panels
    Replies: 3
    Last Post: 05-23-2009, 12:34 AM
  5. PHP 4.4.0 + EA 0.9.3 + IonCube 4.4 Loader + ZO 2.5.10a is that possible?
    By rainy_day in forum Hosting Security and Technology
    Replies: 28
    Last Post: 10-12-2005, 02:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •