Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2008
    Posts
    166

    Slow RX with X9DRFF and Intel Corporation 82574L

    Hi,
    I was looking around the web for possible solutions but there are seems to be none.
    Here is a case:
    Intel Corporation 82574L on board with Supermicro X9DRFF mobo.
    TX speed is rock solid. Server is sitting on 1gbit shared and we are getting 200Mb/sec outgoing. But as for RX incoming it does not get any higher than 5-7mbit. Checked cables and switches - all the same, changed cables and switches - all the same, slow RX, slow incoming.
    2.7 Bios, e100e driver, version 2.5.4
    I have seen threads about complete network connection drops with those nics but nothing about slow connectivity.

    Did any of you guys experience this with any kernels?
    In my case i have 2.6.32-042stab081.5 openvz kernel running about 50 vps on this server right now.

    Thank you for your answers in advance.

  2. #2
    Join Date
    Nov 2006
    Location
    USA
    Posts
    762
    What is the output of ethtool and ifconfig?

  3. #3
    Join Date
    Aug 2008
    Posts
    166
    Nothing major but I see now that ethtool -i shows driver version 2.1.4-k instead of 2.5.4
    2.5.4 in the actual one I compiled into kernel. Looks like reboot was not enough to dump old nic driver.

    filename: /lib/modules/2.6.32-042stab081.5/kernel/drivers/net/e1000e/e1000e.ko
    version: 2.5.4-NAPI
    description: Intel(R) PRO/1000 Network Driver
    Code:
    # ethtool -S eth0
    NIC statistics:
         rx_packets: 292164784
         tx_packets: 357731643
         rx_bytes: 68859066620
         tx_bytes: 266035012570
         rx_broadcast: 1748521
         tx_broadcast: 62787
         rx_multicast: 1078271
         tx_multicast: 24
         rx_errors: 0
         tx_errors: 0
         tx_dropped: 0
         multicast: 1078271
         collisions: 0
         rx_length_errors: 0
         rx_over_errors: 0
         rx_crc_errors: 0
         rx_frame_errors: 0
         rx_no_buffer_count: 0
         rx_missed_errors: 0
         tx_aborted_errors: 0
         tx_carrier_errors: 0
         tx_fifo_errors: 0
         tx_heartbeat_errors: 0
         tx_window_errors: 0
         tx_abort_late_coll: 0
         tx_deferred_ok: 0
         tx_single_coll_ok: 0
         tx_multi_coll_ok: 0
         tx_timeout_count: 0
         tx_restart_queue: 0
         rx_long_length_errors: 0
         rx_short_length_errors: 0
         rx_align_errors: 0
         tx_tcp_seg_good: 5366848
         tx_tcp_seg_failed: 0
         rx_flow_control_xon: 0
         rx_flow_control_xoff: 0
         tx_flow_control_xon: 0
         tx_flow_control_xoff: 0
         rx_long_byte_count: 68859066620
         rx_csum_offload_good: 288668289
         rx_csum_offload_errors: 466
         rx_header_split: 75584062
         alloc_rx_buff_failed: 0
         tx_smbus: 0
         rx_smbus: 2817888
         dropped_smbus: 2817888
         rx_dma_failed: 0
         tx_dma_failed: 0
    Code:
    # ethtool -i eth0
    driver: e1000e
    version: 2.1.4-k
    firmware-version: 2.1-2
    bus-info: 0000:04:00.0
    supports-statistics: yes
    supports-test: yes
    supports-eeprom-access: yes
    supports-register-dump: yes
    supports-priv-flags: no
    Code:
    # ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:25:90:83:24:26
              inet6 addr: fe80::225:90ff:fe83:2426/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:9000  Metric:1
              RX packets:292282809 errors:0 dropped:0 overruns:0 frame:0
              TX packets:357864533 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:66558018735 (61.9 GiB)  TX bytes:263184418525 (245.1 GiB)
              Interrupt:16 Memory:dfc00000-dfc20000

  4. #4
    Join Date
    Aug 2006
    Location
    Ashburn VA, San Diego CA
    Posts
    4,571
    It's more likely an upstream issue. This is a 'tried and trued' NIC used on countless boards and is known to be very stable.
    Fast Serv Networks, LLC | AS29889 | Fully Managed Cloud, Streaming, Dedicated Servers, Colo by-the-U
    Since 2003 - Ashburn VA + San Diego CA Datacenters

  5. #5
    Join Date
    Apr 2009
    Location
    Romania
    Posts
    472
    Run some speed tests with another server connected in the same switch and same network/vlan.
    PidginHost.com - Managed dedicated servers, cloud servers and software development.

  6. #6
    Quote Originally Posted by FastServ View Post
    It's more likely an upstream issue. This is a 'tried and trued' NIC used on countless boards and is known to be very stable.
    Would agree with this. Unless there are hardware faults it's an upstream problem. Who is providing the bandwidth? Run some traces and see if the speed is the same to all locations.

    You said it's shated gigabit. Check if there's congestion on rx in the network.
    Hyperconnezion - your fast path to success
    IT management, Cloud and Data Center Services in Asia Pacific

Similar Threads

  1. Intel 82574L Problems?
    By Branzone in forum Colocation and Data Centers
    Replies: 8
    Last Post: 04-13-2012, 07:32 PM
  2. Flaky networking in Supermicro X8SIL with 82574L?
    By steve999 in forum Colocation and Data Centers
    Replies: 17
    Last Post: 03-05-2011, 03:43 AM
  3. Intel 82574L with Debian
    By bhavicp in forum Colocation and Data Centers
    Replies: 2
    Last Post: 05-26-2010, 08:11 AM
  4. Replies: 9
    Last Post: 05-22-2008, 10:33 AM
  5. Sole Proprietor, Partnership, Corporation, Limited Liability Corporation (LLC)
    By Novice2k in forum Running a Web Hosting Business
    Replies: 2
    Last Post: 07-22-2003, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •