Results 1 to 8 of 8
  1. #1

    Error while installing Ghost Blogging platform

    Hi,

    I am receiving an error while I try to install Ghost Blogging Platform.

    I could install node successfully and no error was reported while the installation. Now when I give the command :npm install --production I receive the following error.

    > [email protected] install /ghost/node_modules/sqlite3
    > node build.js

    [sqlite3]: Checking for node-sqlite3.s3.amazonaws.com/Release/node_sqlite3-v2.1.a-node-v11-linux-x64.tar.gz
    [sqlite3]: Downloaded to: ghost/node_modules/sqlite3/node-sqlite3-Release/node_sqlite3-v2.1.a-node-v11-linux-x64.tar.gz
    [sqlite3]: Checking for node-sqlite3.s3.amazonaws.com/Release/node_sqlite3-v2.1.a-node-v11-linux-x64.sha1.txt
    [sqlite3]: Sha1sum matches! 822cc5103a2d6788ff2b6882ea98675a387bd45e
    [sqlite3]: Extracting to lib/binding/Release
    [sqlite3]: Testing the binary failed: "Command failed:
    module.js:356
    Module._extensions[extension](this, filename);
    ^
    Error: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ghost/node_modules/sqlite3/lib/binding/Release/node-v11-linux-x64/node_sqlite3.node)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (ghost/node_modules/sqlite3/lib/sqlite3.js:7:15)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    "
    [sqlite3]: Attempting source compile...
    Build failed
    [sqlite3]: 1
    npm ERR! weird error 1
    npm ERR! not ok code 0


    I am stuck now. Could any one please advice. Also I am having apache + nginx running on the server. So is there a need to stop the apache while installing Ghost. The os I am using is cent os 2.6.18.

    Thanks and Regards,
    Arun Kurian

  2. #2
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    5,842
    Do you have the C compiler installed?
    Code:
    yum groupinstall "Development tools"
    Even so, I think CentOS 6 only runs glibc version 2.12 so if this really needs 2.14 then you have a problem...
    Chris

    "Some problems are so complex that you have to be highly intelligent and well informed just to be undecided about them." - Laurence J. Peter

  3. #3
    Thanks for the prompt response.
    I tried yum groupinstall "Development tools" and all the packages are downloaded. But still the the issue persist.

    Is there any way to check the glibc version

    Regards,
    Arun

  4. #4
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    5,842
    ldd --version
    Chris

    "Some problems are so complex that you have to be highly intelligent and well informed just to be undecided about them." - Laurence J. Peter

  5. #5
    It shows -- ldd (GNU libc) 2.5

    So this might be causing the problem right?
    Is there any way to update it. I am having a server with cPanel and WHM in it. Will the upgrade cause any issues to the cPanel. Also any thing I should check on before I upgrade?

  6. #6
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    5,842
    glibc is the heart of the operating system. IDK if it's even possible to update it without upgrading the OS, but for sure I wouldn't attempt it on a production system.

    As I said, even CentOS 6 won't give you 2.14 so I guess if you really need it Fedora would be the way to go - and that won't be supported on cPanel.

    Your best bet is to go back to the source of the application you're trying to install - either compile it for yourself with your own glibc or get a version that's compatible with CentOS 5.
    Chris

    "Some problems are so complex that you have to be highly intelligent and well informed just to be undecided about them." - Laurence J. Peter

  7. #7
    Thanks for the update.

  8. #8
    Join Date
    Apr 2000
    Location
    Brisbane, Australia
    Posts
    1,558
    Plenty of Ghost install guides at http://ghost.centminmod.com/how-to-i...ging-platform/ to choose from

    I had no probs installing Ghost on CentOS 6.4 with Centmin Mod Nginx stack http://ghost.centminmod.com/ghost-no...d-nginx-stack/
    : CentminMod.com Nginx Installer (Nginx 1.11, PHP-FPM 5.4-5.6, 7.0 & 7.1, MariaDB 10 + ngx_pagespeed + HTTP2 + lua) for CentOS 6 & 7
    : Centmin Mod .09 beta - Nginx HTTP/2+ Letsencrypt Free SSL (beta testing) support

Similar Threads

  1. Error While Installing SolusVm
    By Linux_Nrj in forum Hosting Software and Control Panels
    Replies: 4
    Last Post: 02-14-2012, 09:20 AM
  2. mysql error on installing
    By guitartrash88 in forum Hosting Security and Technology
    Replies: 4
    Last Post: 05-28-2010, 11:12 AM
  3. Replies: 25
    Last Post: 06-05-2008, 09:38 PM
  4. installing hypervm error
    By rahuldevra in forum Hosting Security and Technology
    Replies: 4
    Last Post: 11-13-2007, 06:24 PM
  5. error installing proftpd
    By ayejohn in forum Hosting Security and Technology
    Replies: 4
    Last Post: 09-07-2004, 09:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •