Results 1 to 15 of 15
  1. #1

    Please HELP me Urgent

    Hello,

    I'm getting following error message at hostdegopro.com/clients/ .

    Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects 4 in /home/hostdego/public_html/clients/newedge/front.php on line 0

    Can you please HELP me ? How can i fix it
    Last edited by mournp; 04-25-2012 at 04:48 PM. Reason: Forget to mention domain

  2. #2
    You'll have to re-encode your scripts with the newer version of Guard.

    From: http://forums.zend.com/viewtopic.php?f=57&t=6595

    "Please note this Loader will not load PHP 5.2 code encoded with previous version of Guard. All PHP files must be re-encoded to run in PHP 5.3."
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  3. #3
    Do i have to setup Zend Loader only or i have to setup Zend Guard 5.1 ?

  4. #4
    It appears Zend has "no plans" for Guard loader to support backwards compatible byte translation.

    Your script might need re-encoding with PHP 5.3 project settings. Did you check your PHP version?
    Last edited by paraiba; 04-25-2012 at 05:20 PM.
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  5. #5
    Brother i have no idea about those program

  6. #6
    First of all, is it WHMCS?
    To execute encoded application on PHP 5.3 runtime,
    you need to encode a new version of the application using zendenc53 from command line or Zend Guard 5.5.0 with a PHP 5.3 project.

    This is actually what the file format error means.

    If you cannot encode the application for PHP 5.3, you can still install Zend Server PHP 5.2 with Zend Loader, or PHP 5.2 with Zend Optimizer and run the current encoded application on PHP 5.2 server.

    You ought to learn your PHP version and Zend Loader version.

    Could you create this file and upload to your website, please?

    <?php

    // Show all information, defaults to INFO_ALL
    phpinfo();

    // Show just the module information.
    // phpinfo(8) yields identical results.
    phpinfo(INFO_MODULES);

    ?>

    It will tell you PHP version and Zend version. Then, you will need to change your Zend Loader version, did you understand?

    Hope this helps
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  7. #7
    Quote Originally Posted by paraiba View Post
    First of all, is it WHMCS?
    To execute encoded application on PHP 5.3 runtime,
    you need to encode a new version of the application using zendenc53 from command line or Zend Guard 5.5.0 with a PHP 5.3 project.

    This is actually what the file format error means.

    If you cannot encode the application for PHP 5.3, you can still install Zend Server PHP 5.2 with Zend Loader, or PHP 5.2 with Zend Optimizer and run the current encoded application on PHP 5.2 server.

    You ought to learn your PHP version and Zend Loader version.

    Could you create this file and upload to your website, please?

    <?php

    // Show all information, defaults to INFO_ALL
    phpinfo();

    // Show just the module information.
    // phpinfo(8) yields identical results.
    phpinfo(INFO_MODULES);

    ?>

    It will tell you PHP version and Zend version. Then, you will need to change your Zend Loader version, did you understand?

    Hope this helps


    Hello please visit http://hostdegopro.com/test.php

  8. #8
    I think, your software might be supporting ioncube too.
    Perhaps, you ought to try to load your software with ioncube. It seems zend will not work for you.

    Edit: I'm checking your file at the moment, please hold on.
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  9. #9
    In that case, you need to downgrade your PHP version to PHP 5.2 in order to use this software properly. You should not do that. You ought to use latest PHP version.

    Are you developer of that software? If yes, you should re-encode your software to run in PHP 5.3. If you are not developer, you ought to talk to your software provider to re-encode it for PHP 5.3. Is your software compatible with ioncube? If yes, you can load it with ioncube.

    What is that script? Is it WHMCS?
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  10. #10
    Quote Originally Posted by paraiba View Post
    In that case, you need to downgrade your PHP version to PHP 5.2 in order to use this software properly. You should not do that. You ought to use latest PHP version.

    Are you developer of that software? If yes, you should re-encode your software to run in PHP 5.3. If you are not developer, you ought to talk to your software provider to re-encode it for PHP 5.3. Is your software compatible with ioncube? If yes, you can load it with ioncube.

    What is that script? Is it WHMCS?
    That is ClientExe

  11. #11
    There should be a clientexec_4.4.1_zend-5.3.zip. That's the file you need to use. I think, you are using a previous or wrong version of clientexe.

    All I want to say again, you may want to use ioncube. Please, always get a back up before doing anything. Then, you can upgrade or change your files.
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  12. #12
    Quote Originally Posted by paraiba View Post
    There should be a clientexec_4.4.1_zend-5.3.zip. That's the file you need to use. I think, you are using a previous or wrong version of clientexe.

    All I want to say again, you may want to use ioncube. Please, always get a back up before doing anything. Then, you can upgrade or change your files.
    Can i remove http://hostdegopro.com/test.php page? Some one told me to remove that page security reason.

  13. #13
    Yes, mate. You should remove that page.
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  14. #14
    Problem fixed after installing updated ClientExe Version

  15. #15
    Very nice. I hope everything would be perfect for you.
    Regards
    - I am a PHP developer. I'm not a webhosting owner, I have never run a webhosting business before.
    - English is not my primary language.

  16. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Similar Threads

  1. Validating a project Vs PHP coding structure - URGENT URGENT !!!!!!!!!!!!!!
    By helpwanted123 in forum Programming Discussion
    Replies: 6
    Last Post: 12-21-2006, 05:30 PM
  2. Real Urgent ... need urgent windows 2003 administrator
    By kamyana in forum Employment / Job Offers
    Replies: 2
    Last Post: 10-23-2004, 02:04 PM
  3. very strange and very entertaining websites urgent urgent
    By appletreats in forum Web Hosting Lounge
    Replies: 16
    Last Post: 01-22-2002, 12:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •