Results 1 to 9 of 9
  1. #1

    virtualmin install help


    I have followed many guides, especially:

    I followed his exact steps, and got an error: /tmp directory is mounted noexec. installation cannot continue.

    I know you you're supposed to edit something in the /tmp for the noexec but I don't even know the commands to access it without getting permission denied.

    I have nothing of SSH commands to access certain files/edit. I followed what was needed through the process, but can someone tell me the exact commands without getting the permission denied?

    I have been at this for 2 days.

    Thank you very much!
    Last edited by digimonrpg; 04-01-2012 at 03:19 PM.

  2. #2
    All you need to do m8 is 1st make sure webmin is installed.

    Then download the and upload it to your root directory

    then use this command (use putty)


    follow the on screen functions

    once its finished go to

    enter root and your password

  3. #3
    Join Date
    Oct 2007
    Central Indiana
    It sounds like you are trying to download and run the installation script from your /tmp folder. Try running the script from a subfolder in your home directory instead. You should not modify the noexec,nosuid options set for your /tmp folder, they are set this way to improve security.
    HostingXchange | 100% USA-Based Tech Support
    Shared | Reseller | VPS | Consulting | .NET Development

    Top dollar paid for hosting companies. Please contact us...

  4. #4
    I'm confused. On the site, it states that you should not have webmin installed... I'm really confused. I tried unmount the /tmp directory, but to no avail... same error

    What is M8? how would i install webmin? doesn't it comes with the virtualmin installation through

    @hostingxchange: i don't have a home directory. how would i do this? I'm just following guides. im quite new to this. sorry

    This is what im doing right now: access SSH (putty), vi, copy the code's contents fro the GPL file and insert them. set the chmod to 744 and run the file using ./ Y to execute. Error: /tmp directory is mounted noexec. installation cannot continue.

    Last edited by digimonrpg; 04-01-2012 at 05:40 PM.

  5. #5
    My apology for the double post, but i am unable to edit my post and don't want to misinform hostingxchange.

    There is a home directory on my vz log in, but how would i accomplish what you're instructing?


  6. #6
    Join Date
    Mar 2008

  7. #7
    thank you all

    i managed to install virtualmin, but having a problem with the DNS server. it's not working.

    I get this error when creating a new virtusl server: .. BIND DNS domain failed! : Failed to open /var/named/chroot/var/named/ for writing : Bad file descriptor at /usr/libexec/webmin/ line 1360.

  8. #8
    Join Date
    Mar 2012
    remove bind. use a record from domain panel its instant update and better then dns.

  9. #9
    Do you have a link on how to do that? I'm a newbie to virtualmin and SSH. Thanks for replying Survro!

  10. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Similar Threads

  1. Virtualmin easy install .sh script
    By steve_fortune in forum VPS Hosting
    Replies: 4
    Last Post: 12-09-2010, 09:28 PM
  2. how to install virtualmin in Fedora server help..
    By jebra in forum Dedicated Server
    Replies: 1
    Last Post: 11-24-2010, 02:09 PM
  3. Error trying to install Virtualmin
    By 08A4210 in forum VPS Hosting
    Replies: 5
    Last Post: 11-08-2010, 07:21 AM
  4. FFMPEG install Centos 5.3 with Virtualmin
    By Newbie in forum Hosting Security and Technology
    Replies: 11
    Last Post: 09-02-2009, 04:38 PM
  5. WANTED Experienced! Install Virtualmin Suexec
    By wishiwashere in forum Employment / Job Offers
    Replies: 4
    Last Post: 03-20-2004, 12:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts