hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Software and Control Panels : WHMCS cPanel/WHM Auto Creation Error (Login Failed)
Reply

Forum Jump

WHMCS cPanel/WHM Auto Creation Error (Login Failed)

Reply Post New Thread In Hosting Software and Control Panels Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27

WHMCS cPanel/WHM Auto Creation Error (Login Failed)


I'm having this problem with only one of my servers.
WHMCS can't create cPanel accounts automatically because of this error:
Quote:
Module Create Failed - Service ID: 738 - Error: Login Failed
- 25/03/2012 19:19 - admin - 12.345.678.9
I've searched around a while looking for a solution.
I have all the server details correct (username password and hash), as I can log myself in from my computer.
I can login using SSL mode or not.
I've whitelisted WHMCS IP in CSF and cPhulk.

Any help is appreciated.
Thanks.



Sponsored Links
  #2  
Old
Newbie
 
Join Date: Oct 2011
Posts: 15
Hi,

Have you tried updating the WHM/Cpanel ?

Issue may be solved if you update/upgrade the WHM/Cpanel. I assume you know how to do that.

  #3  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by madathil View Post
Hi,

Have you tried updating the WHM/Cpanel ?

Issue may be solved if you update/upgrade the WHM/Cpanel. I assume you know how to do that.
I just ran the update. Still getting the same error.

Sponsored Links
  #4  
Old
Web Hosting Master
 
Join Date: Jul 2009
Location: CT
Posts: 792
In WHM, generate a new access hash and update WHMCS.
In WHMCS, check Tick to use SSL Mode for Connections.

__________________
Find a new pet for your home ... Find a new home for your pet - WeGotPets.com
Domain reseller accounts - NamesVibe

  #5  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by GORF View Post
In WHM, generate a new access hash and update WHMCS.
In WHMCS, check Tick to use SSL Mode for Connections.
Still getting the same error after doing this.

  #6  
Old
Newbie
 
Join Date: Oct 2011
Posts: 15
Hi,

There could be two possible scenario:


1. The login details under Setup > Servers > Edit are incorrect. Please ensure you are using either the username + access hash combination or the username + password combination and that the login details are correct.
2. The Brute Force Protection settings are preventing WHMCS from creating/suspending/terminating accounts via the cPanel API. Please adjust the BFP settings in WHM.

  #7  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by madathil View Post
Hi,

There could be two possible scenario:


1. The login details under Setup > Servers > Edit are incorrect. Please ensure you are using either the username + access hash combination or the username + password combination and that the login details are correct.
2. The Brute Force Protection settings are preventing WHMCS from creating/suspending/terminating accounts via the cPanel API. Please adjust the BFP settings in WHM.
1. The details are correct because I can login when pressing the "WHM" button.
2. There are no records of my WHMCS IP being blocked in CSF or cPhulk. I added it to both whitelists to be sure.

  #8  
Old
Server Management Specialist
 
Join Date: Nov 2009
Location: /etc/my.cnf
Posts: 9,496
Is your WHMCS installation on the same server or a remote server?

__________________
LeapHost High Performance Wordpress & Magento Hosting Powered By Litespeed
Fast Dedicated Servers | Uptime Cloud Monitoring | Server Management Specialist
24/7 Ticket > Phone > Live Chat > Skype | Be A Talkative Soul > Visit Our LH Forums


  #9  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by cd/home View Post
Is your WHMCS installation on the same server or a remote server?
It is on a remote server.

  #10  
Old
Community Leader
 
Join Date: Oct 2002
Location: Mayberry
Posts: 20,091
Quote:
Originally Posted by B4LHost View Post
1. The details are correct because I can login when pressing the "WHM" button.
That suggests you're using the password. Did you remove the hash? It should be one or the other.

__________________
Having problems, or maybe questions about WHT? Head over to the help desk!



  #11  
Old
Web Hosting Master
 
Join Date: Sep 2006
Location: Cardiff - United Kingdom
Posts: 1,568
As bear says, remove the hash and try again. If it works (i.e. with username and password login) then you know it's an issue with the hash.

__________________
Plagiarism Guard - Protect Against Content Theft
Tristan Perry - Personal blog

  #12  
Old
Premium Member
 
Join Date: Oct 2009
Location: England, United Kingdom
Posts: 9,205
Just a get a system admin to check it for you. It'll only cost you $5-20. That's what they do. They will tell you what was wrong too. Or figure it for yourself if you have the time.

__________________
HostXNow - http://www.hostxnow.com | Since 2009
Fast, Secure and Reliable [UK/USA] Web Hosting - Reseller Hosting - VPS Hosting
cPanel/WHM CloudLinux (Multi PHP) Offsite Backups LiteSpeed TrendyTools Softaculous
Check our customer testimonials page for 100% real customer testimonials at ShopperApproved


  #13  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by Tristan Perry View Post
As bear says, remove the hash and try again. If it works (i.e. with username and password login) then you know it's an issue with the hash.
Still getting the error after removing hash and only using the password.
I can click the "WHM" button and it will log me in.

  #14  
Old
Web Hosting Master
 
Join Date: Jul 2009
Location: CT
Posts: 792
I have seen using hash + username + SSL with no password work on certain server setups.

__________________
Find a new pet for your home ... Find a new home for your pet - WeGotPets.com
Domain reseller accounts - NamesVibe

  #15  
Old
Newbie
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by GORF View Post
I have seen using hash + username + SSL with no password work on certain server setups.
That does not work on my server.

Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
WHM / WHMCS Auto account creation very slow irdeto Reseller Hosting 10 01-27-2012 03:03 PM
Auto-Host 2 Script | WHM Auto-Account Creation | Paypal & WHM listenmirndt Other Web Hosting Related Offers 0 10-05-2004 10:42 AM
Auto-Host 2 Script | WHM Auto-Account Creation | Paypal & WHM listenmirndt Other Offers & Requests 8 09-28-2004 08:36 AM
Auto-Host 2 Script | WHM Auto-Account Creation | Paypal & WHM listenmirndt Other Web Hosting Related Offers 3 09-07-2004 04:49 AM
Auto-Host 2 Script | WHM Auto-Account Creation | Paypal & WHM listenmirndt Other Web Hosting Related Offers 3 08-10-2004 01:00 AM

Related posts from TheWhir.com
Title Type Date Posted
WHMCS Encourages Users to Upgrade as Part of Important Security Update Web Hosting News 2014-08-27 12:05:55
WHMCS Security Issue Allows for Information Disclosure Web Hosting News 2013-10-25 09:30:46
WHMCS Releases Patch to Address Critical Security Issue Web Hosting News 2013-10-04 16:12:43
Open-Xchange Integrates App Suite with cPanel and WHMCS Web Hosting News 2013-09-10 11:36:34
WHMCS Releases Version 5.2 of Web Hosting Billing Solution Web Hosting News 2013-04-14 22:35:37


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
WHT Host Brief Email:

We respect your privacy. We will never sell, rent, or give away your address to any outside party, ever.

Advertisement:
Web Hosting News:
WHT Membership
WHT Membership



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?