Results 1 to 16 of 16
  1. #1

    Unhappy Nightmare installing mcrypt ...help please!

    Hi, I want to run magento on a VPS just purchased. However running the magento compatibility checks reveals 1 error which is:

    "You are missing the mcrypt extension"

    I've tried and tried to get mcrypt installed but to no avail

    Server info: VPS server, Linux 2.6.18-028stab079.1, CentOS 5.6, Parallels Plesk 10.2.0, PHP 5.2.10, MySQL 5.0.77

    N.B I'm a relative newbie with SSH and server administartion outside of Cpanel/WHM

    OK after googling the 1st thing I came across was using yum to install mcrypt:

    Steps I followed were:

    1. Type "yum install mcrypt*". Say yes to the prompts.
    2. Type "yum install mhash*". Say yes to the prompts.
    3. Type "yum install php-mcrypt*". Say yes to the prompts.
    4. Type "yum install php-mhash*". Say yes to the prompts.
    5. Restart server

    All steps seemed successful apart from step 1: "yum install mcrypt*"

    Which gives me message 'No package mcrypt available'

    So I decided to try installing it manually, I downloaded the mcrypt 2.6.4 files, unzipped and uploaded with WinSCP to a folder

    named mcrypt in the root of my server. Then I:

    1. cd to mcrypt directory
    2. typed ./configure
    3. It returns error 'no acceptable C compliler found in $PATH'

    Ok after more googling it seems I need to install a compiler GCC seems to be what everyone uses.

    So my next steps are:

    1. yum install gcc
    2. which returns another error: 'Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-

    58.el5_6.3.x86_64 (updates)'

    I'm not really sure what that means but I think it seems to be saying gcc needs an older or equal to version of kernel headers

    2.2.1 but I have a newer version?

    Well that is about as much as I know what to do, I'm completely stumped now and don't know how to move forward with this The

    annoying thing is I know in Cpanel/WHM you can install mcrypt with a couple of clicks through WHM>easyapache. I wish plesk had

    this feature.

    Does anyone have any ideas how I can install mcrypt or fix the issues above so I can install gcc? I would be very grateful as I

    feel like banging my head against a brick wall at the moment!

  2. #2
    Join Date
    Aug 2002
    Location
    Milton Keynes
    Posts
    352
    If you've managed to install both the php-mcrypt and php-mhash packages then it will have already installed all the dependencies you need for them and don't need to do anything else.

  3. #3
    Quote Originally Posted by drspliff View Post
    If you've managed to install both the php-mcrypt and php-mhash packages then it will have already installed all the dependencies you need for them and don't need to do anything else.
    wow thast for the quick reply drspliff however when I run the compatibility check I still receive the error;

    "You are missing the mcrypt extension"

    php-mcrypt and php-mhash definitely appear to be installed as when I try to yum install then again it says "...already installed and latest version. Nothing to do"

  4. #4
    Join Date
    Jul 2009
    Location
    UK
    Posts
    1,308
    what happens when you do a " yum search mcrypt "

    Its possible that the mcrypt package is actually under another name.
    Live Chat Support Software for your Business website - IMsupporting.com

  5. #5
    Quote Originally Posted by lynxus View Post
    what happens when you do a " yum search mcrypt "

    Its possible that the mcrypt package is actually under another name.
    Thanks for stopping by.. much appreciated. When I do 'yum search mcrypt' I get the following:

    [[email protected] ~]# yum search mcrypt
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.sov.uk.goscomb.net
    * extras: mirror.sov.uk.goscomb.net
    * updates: mirrors.coreix.net

    base | 2.1 kB 00:00

    extras | 2.1 kB 00:00

    updates | 1.9 kB 00:00
    Excluding Packages in global exclude list
    Finished
    =============================== Matched: mcrypt ================================
    libmcrypt.x86_64 : Encryption algorithms library
    libmcrypt-devel.x86_64 : Development libraries and headers for libmcrypt
    php-mcrypt.x86_64 : Standard PHP module provides mcrypt library support
    [[email protected] ~]#

  6. #6
    Join Date
    Jul 2009
    Location
    UK
    Posts
    1,308
    You have restarted the webserver yeah?
    ( Not the server, But the process )
    Live Chat Support Software for your Business website - IMsupporting.com

  7. #7
    Quote Originally Posted by lynxus View Post
    You have restarted the webserver yeah?
    ( Not the server, But the process )
    Hi lynxus... I have just been restarting the server through plesk, is this incorrect?

  8. #8
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    Download the required rpm's for the 5.2 version from
    http://www6.atomicorp.com/channels/a...s/5/i386/RPMS/

    and clear dependencies one by one ..easy job
    Sam
    Supportlobby.com - Expertise in Windows/Linux server support, IaaS and PaaS Management
    Spiralbean.com - Custom Software Development
    Email: exec @ activelobby.net | Skype: unni_active

  9. #9
    Quote Originally Posted by activelobby4u View Post
    Download the required rpm's for the 5.2 version from...

    and clear dependencies one by one ..easy job
    Hi, thanks for helping out ...I don't suppose you could elaborate on that could you? I am a complete beginner really

  10. #10
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    1. Its php specific version rpm's you have to download
    2. Run "rpm -Uvh *.rpm"

    this will gov you some dependencies, you have to download the dependent rpm's from rpm.pbone.net and run the command 2 again.
    Sam
    Supportlobby.com - Expertise in Windows/Linux server support, IaaS and PaaS Management
    Spiralbean.com - Custom Software Development
    Email: exec @ activelobby.net | Skype: unni_active

  11. #11
    thanks active... I ran that command and see 4 failed dependencies, I'm still not entirely how to use the rpm's though

    If I provide the SSH access details will someone be willing to sort this out for me please? I will be happy to pay them. Anyone interested in doing it for 10? Ideally activelobby4u or lynxus or someone with lots of posts (500+), as obviously it need to be someone I can trust!

    PM me or reply on here please if interested (I'm not sure as a new user if I can PM or not).

    Help me obi-wan kenobi... you're my only hope!

  12. #12
    Please check how php is installed as cgi or dso

    if DSO you will need to compile from source

    If you need we can assist you on of My admin will assist you
    Hillock Hosting
    Unlimited Hosting Solution
    Reliable Shared | Reseller| VPS Hosting Services

  13. #13
    Join Date
    Aug 2005
    Location
    Durham, NC USA
    Posts
    195
    If you're running a standard CentOS install (and it does seem that way) you may just need to completely stop and restart the server. I don't entirely recall, but I think that a restart in Plesk may just reload the config file, which doesn't help.

    Instead, stop the web server, and once it has stopped (check by trying to load a page), start it again. If you still get the same error, check your log files (should be /var/www/httpd/access.log and /var/www/httpd/error.log) to see if there's some problem loading the mcrypt.so extension when you restart.

    You may also want to check that the config file is in place and active -- it should be /etc/php.d/mcrypt.ini and simply include the line

    extension=mcrypt.so;
    Netmar Web Services - Reliable Web Hosting for 15 years
    Shared hosting, business hosting, domain name registration, and VMware virtual servers
    Specializing in Drupal hosting
    Call 866-363-8627 (toll-free) and ask about our Drupal accounts

  14. #14
    Thanks for the replies & help everyone. I ended up letting activelobby sort it out for me (for a small fee), wish I could post an accurate reply to say what was done to help people in the future but unfortunately I don't really know, I think the PHP was upgraded and mcrypt installed along with that. Anyway it would have been nice to sort it out myself, but tbh I was just happy to get it up & running and couldn't really afford more wasting more time on it!

    Oh and activelobby were very good and got it done quickly with no fuss, and good communication, I would happily recommend them if anyone needs any server management help.

  15. #15
    Join Date
    Jul 2009
    Location
    UK
    Posts
    1,308
    Glad you got it working in the end.
    +1 for activelobby
    Live Chat Support Software for your Business website - IMsupporting.com

  16. #16
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    Thanks deoxymono.

    We did exactly the steps i suggested in my original post. Downloaded and installed the rpm's from atomicrocketturtle ...However there were residues from your attempts , which was cleared and the upgrade was done clean by our tech
    Sam
    Supportlobby.com - Expertise in Windows/Linux server support, IaaS and PaaS Management
    Spiralbean.com - Custom Software Development
    Email: exec @ activelobby.net | Skype: unni_active

Similar Threads

  1. Installing mcrypt on LIteSpeed
    By hD-Scott in forum Hosting Software and Control Panels
    Replies: 8
    Last Post: 01-14-2010, 01:06 AM
  2. installing curl and mcrypt via Shell
    By saj in forum Hosting Security and Technology
    Replies: 1
    Last Post: 12-23-2005, 07:37 AM
  3. Installing mcrypt into PHP
    By Skeptical in forum Hosting Security and Technology
    Replies: 2
    Last Post: 11-06-2004, 06:55 AM
  4. Installing mcrypt
    By [inx]Olly in forum Hosting Security and Technology
    Replies: 8
    Last Post: 11-21-2003, 12:06 PM
  5. Steps for installing mcrypt?
    By DaveWeb in forum Hosting Security and Technology
    Replies: 1
    Last Post: 10-06-2002, 01:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •