Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2010
    Posts
    325

    openssl / failed pop3

    Outlook error:

    Task 'User - Receiving' reported error (0x800CCC0F) : 'The connection to the server was interrupted. If this problem continues, contact your server administrator or Internet service provider (ISP).'
    [email protected] [~]# yum list installed | grep openssl
    openssl.i686 0.9.7a-43.17.el4_8.5 installed
    openssl-devel.i386 0.9.7a-43.17.el4_8.5 installed
    openssl096b.i386 0.9.6b-22.46.el4_7 installed
    xmlsec1-openssl.i386 1.2.6-3.1 installed
    I was told by cpanel this:

    I would suggest disabling any extraneous repositories, and run yum update to ensure that it's able to run through to completion. After that, you should only have 2x RPMs for openssl installed, and 2x for openssl-devel.
    It looks like some IMAP and POP connections are failing due to missing symbols relating to openssl:
    Jun 1 15:37:42 server dovecot: pop3-login: pop3-login: symbol lookup error: pop3-login: undefined symbol: SSL_get_current_compression
    Jun 1 15:37:42 server dovecot: pop3-login: pop3-login: symbol lookup error: pop3-login: undefined symbol: SSL_get_current_compression
    Jun 1 15:37:42 server dovecot: dovecot: child 30648 (login) returned error 127 (latest ip=208.74.121.102)
    Jun 1 15:37:42 server dovecot: dovecot: child 30648 (login) returned error 127 (latest ip=208.74.121.102)
    Jun 1 15:37:51 server dovecot: imap-login: imap-login: symbol lookup error: imap-login: undefined symbol: SSL_get_current_compression
    Jun 1 15:37:51 server dovecot: dovecot: child 30923 (login) returned error 127 (ip=208.74.121.102)
    Jun 1 15:37:51 server dovecot: dovecot: child 30923 (login) returned error 127 (ip=208.74.121.102)


    How do I correct this?


    [email protected] [~]# uname -r
    2.6.9-89.0.19.ELsmp
    [email protected] [~]# cat /etc/redhat-release
    CentOS release 5.6 (Final)

  2. #2
    Join Date
    Sep 2010
    Posts
    325
    I ran rpm -e on the below

    openssl-devel.i386 0.9.7a-43.17.el4_8.5 installed
    openssl096b.i386 0.9.6b-22.46.el4_7 installed
    xmlsec1-openssl.i386 1.2.6-3.1 installed

    Then, yum update.

    Errors


    --> Processing Dependency: python-abi = 2.3 for package: python-elementtree
    --> Processing Conflict: hal conflicts kernel < 2.6.17
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    --> Processing Dependency: perl(String::CRC32) for package: lftp
    --> Processing Dependency: libttf.so.2 for package: VFlib2
    --> Processing Dependency: libgv_perl.so.0 for package: graphviz-perl
    --> Processing Dependency: perl-String-CRC32 for package: lftp
    --> Processing Conflict: kudzu conflicts kernel < 2.6.13
    --> Processing Conflict: autofs conflicts kernel < 2.6.17
    --> Processing Conflict: lksctp-tools conflicts kernel < 2.6.10
    --> Processing Conflict: initscripts conflicts kernel < 2.6.12
    --> Processing Dependency: python-abi = 2.3 for package: python-elementtree
    --> Processing Conflict: hal conflicts kernel < 2.6.17
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    Error: Missing Dependency: libttf.so.2 is needed by package VFlib2
    Error: Missing Dependency: python-abi = 2.3 is needed by package python-elementtree
    Error: Missing Dependency: perl(String::CRC32) is needed by package lftp
    Error: Missing Dependency: perl-String-CRC32 is needed by package lftp
    Error: Missing Dependency: libgv_perl.so.0 is needed by package graphviz-perl
    Error: Unable to satisfy dependencies
    Error: Package lftp needs perl(String::CRC32), this is not available.
    Error: Package VFlib2 needs libttf.so.2, this is not available.
    Error: Package graphviz-perl needs libgv_perl.so.0, this is not available.
    Error: Package lftp needs perl-String-CRC32, this is not available.
    Error: Package kudzu needs kernel < 2.6.13, this is not available.
    Error: Package autofs needs kernel < 2.6.17, this is not available.
    Error: Package lksctp-tools needs kernel < 2.6.10, this is not available.
    Error: Package initscripts needs kernel < 2.6.12, this is not available.
    Error: Package python-elementtree needs python-abi = 2.3, this is not available.
    Error: Package hal needs kernel < 2.6.17, this is not available.

Similar Threads

  1. anybody using OpenSSL?
    By tmax100 in forum Web Hosting Lounge
    Replies: 4
    Last Post: 01-25-2007, 12:44 AM
  2. openssl
    By HD Fanatic in forum Hosting Security and Technology
    Replies: 4
    Last Post: 05-30-2006, 03:20 AM
  3. imap has failed & cppop has failed
    By GusBouras in forum Hosting Security and Technology
    Replies: 1
    Last Post: 05-04-2006, 11:41 AM
  4. 550-Verification failed for \n550 - Sender verify failed
    By Rui in forum Hosting Security and Technology
    Replies: 5
    Last Post: 04-27-2005, 03:23 AM
  5. OpenSSL Help Please !!!!!!!!!!!!!!!
    By oc3 in forum Hosting Security and Technology
    Replies: 1
    Last Post: 08-03-2003, 08:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •