Results 1 to 16 of 16
  1. #1
    Join Date
    Jun 2006
    Posts
    33

    disable innodb in mysql 5.5.12

    Hi

    could any one tell me the correct lines to put in my.cnf to disable innodb

    just upgraded from 5.1.36 and skip-innodb was used to disable innodb but that no longer works, actually stops mysql from starting.
    looks like innodb is started by default

    tried ignore_builtin_innodb but did not seem to work, does it need any thing else added.

    thank you

  2. #2
    Join Date
    Jun 2006
    Posts
    33
    sorted with these two lnes

    ignore_builtin_innodb
    default_storage_engine=MyISAM

  3. #3
    Join Date
    Apr 2005
    Location
    Queen of Arabian Sea
    Posts
    2,434
    great going ...
    Sam
    Supportlobby.com - Specialist in Windows/Linux Server Management
    Spiralbean.com - Custom Software Development
    Email: exec@supportlobby.com | Skype: exec_activelobby

  4. #4
    Join Date
    Jul 2007
    Location
    /dev/zero
    Posts
    140
    To disable InnoDB, use --innodb=OFF or --skip-innodb. In this case, because the default storage engine is InnoDB, the server will not start unless you also use --default-storage-engine to set the default to some other engine.
    Refs:
    1. http://dev.mysql.com/doc/refman/5.5/...arameters.html
    2. http://dev.mysql.com/doc/refman/5.5/...storage-engine
    vpsoffers.com - a modest place for vps offers by sim so dep

  5. #5
    I cannot disable innoDB in ubuntu 12.04

    I've tried adding
    skip-innodb

    skip-innodb
    default_storage_engine=MyISAM

    ignore_builtin_innodb
    default_storage_engine=MyISAM

    and restarting mysql

    and also:

    service mysql start --skip-innodb --default-storage-engine=MyISAM
    The script you are attempting to invoke has been converted to an Upstart
    job, but --skip-innodb is not supported for Upstart jobs.
    thanks

    | Engine | Support |
    +--------------------+---------+
    | MyISAM | YES |
    | CSV | YES |
    | MRG_MYISAM | YES |
    | BLACKHOLE | YES |
    | MEMORY | YES |
    | PERFORMANCE_SCHEMA | YES |
    | ARCHIVE | YES |
    | InnoDB | DEFAULT |
    | FEDERATED | NO |
    Last edited by opaliz; 05-23-2012 at 11:02 AM. Reason: added more info

  6. #6
    Join Date
    Jul 2007
    Location
    /dev/zero
    Posts
    140
    @opaliz: what's your mysql server's version?
    vpsoffers.com - a modest place for vps offers by sim so dep

  7. #7
    Hi @lovelycesar, my version is 5.5.22

  8. #8
    Join Date
    Apr 2000
    Location
    Brisbane, Australia
    Posts
    1,361
    Quote Originally Posted by opaliz View Post
    I cannot disable innoDB in ubuntu 12.04

    I've tried adding
    skip-innodb

    skip-innodb
    default_storage_engine=MyISAM

    ignore_builtin_innodb
    default_storage_engine=MyISAM

    and restarting mysql

    and also:

    service mysql start --skip-innodb --default-storage-engine=MyISAM


    thanks
    you missed one combination and pay attention to difference between underscore and hyphens

    add to my.cnf

    Code:
    innodb=OFF
    default-storage-engine=MyISAM
    : CentminMod.com Nginx Menu Installer (Nginx 1.9, PHP-FPM 5.3-5.6 & 7.0-dev, MariaDB 5.5/10 + ngx_pagespeed) for CentOS
    : Centmin Mod Community Forums

  9. #9
    Thanks, I added

    innodb=OFF
    default-storage-engine=MyISAM
    to /etc/mysql/my.cnf

    then

    sudo service mysql restart
    sudo service apache2 restart
    and I still see:

    | Engine____________| Support |
    +--------------------+---------+
    | MyISAM____________| YES |
    | CSV_______________| YES |
    | MRG_MYISAM________| YES |
    | BLACKHOLE_________| YES |
    | MEMORY____________| YES |
    | PERFORMANCE_SCHEMA| YES |
    | ARCHIVE___________| YES |
    | InnoDB____________| DEFAULT |
    | FEDERATED_________| NO |
    What can be going on here?

  10. #10
    Join Date
    Apr 2000
    Location
    Brisbane, Australia
    Posts
    1,361
    post output from command

    mysqladmin -u root -p var
    wrap in CODE tags
    : CentminMod.com Nginx Menu Installer (Nginx 1.9, PHP-FPM 5.3-5.6 & 7.0-dev, MariaDB 5.5/10 + ngx_pagespeed) for CentOS
    : Centmin Mod Community Forums

  11. #11
    Hi, here is the output

    +---------------------------------------------------+------------------------------------------------------------------------------------------------------------------------+
    | Variable_name | Value |
    +---------------------------------------------------+------------------------------------------------------------------------------------------------------------------------+
    | auto_increment_increment | 1 |
    | auto_increment_offset | 1 |
    | autocommit | ON |
    | automatic_sp_privileges | ON |
    | back_log | 50 |
    | basedir | /usr |
    | big_tables | OFF |
    | binlog_cache_size | 32768 |
    | binlog_direct_non_transactional_updates | OFF |
    | binlog_format | STATEMENT |
    | binlog_stmt_cache_size | 32768 |
    | bulk_insert_buffer_size | 8388608 |
    | character_set_client | latin1 |
    | character_set_connection | latin1 |
    | character_set_database | latin1 |
    | character_set_filesystem | binary |
    | character_set_results | latin1 |
    | character_set_server | latin1 |
    | character_set_system | utf8 |
    | character_sets_dir | /usr/share/mysql/charsets/ |
    | collation_connection | latin1_swedish_ci |
    | collation_database | latin1_swedish_ci |
    | collation_server | latin1_swedish_ci |
    | completion_type | NO_CHAIN |
    | concurrent_insert | AUTO |
    | connect_timeout | 10 |
    | datadir | /var/lib/mysql/ |
    | date_format | %Y-%m-%d |
    | datetime_format | %Y-%m-%d %H:%i:%s |
    | default_storage_engine | InnoDB |
    | default_week_format | 0 |
    | delay_key_write | ON |
    | delayed_insert_limit | 100 |
    | delayed_insert_timeout | 300 |
    | delayed_queue_size | 1000 |
    | div_precision_increment | 4 |
    | engine_condition_pushdown | ON |
    | event_scheduler | OFF |
    | expire_logs_days | 10 |
    | flush | OFF |
    | flush_time | 0 |
    | foreign_key_checks | ON |
    | ft_boolean_syntax | + -><()~*:""&| |
    | ft_max_word_len | 84 |
    | ft_min_word_len | 4 |
    | ft_query_expansion_limit | 20 |
    | ft_stopword_file | (built-in) |
    | general_log | OFF |
    | general_log_file | /var/lib/mysql/econlink.log |
    | group_concat_max_len | 1024 |
    | have_compress | YES |
    | have_crypt | YES |
    | have_csv | YES |
    | have_dynamic_loading | YES |
    | have_geometry | YES |
    | have_innodb | YES |
    | have_ndbcluster | NO |
    | have_openssl | DISABLED |
    | have_partitioning | YES |
    | have_profiling | YES |
    | have_query_cache | YES |
    | have_rtree_keys | YES |
    | have_ssl | DISABLED |
    | have_symlink | YES |
    | hostname | econlink.com.ar |
    | ignore_builtin_innodb | OFF |
    | init_connect | |
    | init_file | |
    | init_slave | |
    | innodb_adaptive_flushing | ON |
    | innodb_adaptive_hash_index | ON |
    | innodb_additional_mem_pool_size | 8388608 |
    | innodb_autoextend_increment | 8 |
    | innodb_autoinc_lock_mode | 1 |
    | innodb_buffer_pool_instances | 1 |
    | innodb_buffer_pool_size | 134217728 |
    | innodb_change_buffering | all |
    | innodb_checksums | ON |
    | innodb_commit_concurrency | 0 |
    | innodb_concurrency_tickets | 500 |
    | innodb_data_file_path | ibdata1:10M:autoextend |
    | innodb_data_home_dir | |
    | innodb_doublewrite | ON |
    | innodb_fast_shutdown | 1 |
    | innodb_file_format | Antelope |
    | innodb_file_format_check | ON |
    | innodb_file_format_max | Antelope |
    | innodb_file_per_table | OFF |
    | innodb_flush_log_at_trx_commit | 1 |
    | innodb_flush_method | |
    | innodb_force_load_corrupted | OFF |
    | innodb_force_recovery | 0 |
    | innodb_io_capacity | 200 |
    | innodb_large_prefix | OFF |
    | innodb_lock_wait_timeout | 50 |
    | innodb_locks_unsafe_for_binlog | OFF |
    | innodb_log_buffer_size | 8388608 |
    | innodb_log_file_size | 5242880 |
    | innodb_log_files_in_group | 2 |
    | innodb_log_group_home_dir | ./ |
    | innodb_max_dirty_pages_pct | 75 |
    | innodb_max_purge_lag | 0 |
    | innodb_mirrored_log_groups | 1 |
    | innodb_old_blocks_pct | 37 |
    | innodb_old_blocks_time | 0 |
    | innodb_open_files | 300 |
    | innodb_purge_batch_size | 20 |
    | innodb_purge_threads | 0 |
    | innodb_random_read_ahead | OFF |
    | innodb_read_ahead_threshold | 56 |
    | innodb_read_io_threads | 4 |
    | innodb_replication_delay | 0 |
    | innodb_rollback_on_timeout | OFF |
    | innodb_rollback_segments | 128 |
    | innodb_spin_wait_delay | 6 |
    | innodb_stats_method | nulls_equal |
    | innodb_stats_on_metadata | ON |
    | innodb_stats_sample_pages | 8 |
    | innodb_strict_mode | OFF |
    | innodb_support_xa | ON |
    | innodb_sync_spin_loops | 30 |
    | innodb_table_locks | ON |
    | innodb_thread_concurrency | 0 |
    | innodb_thread_sleep_delay | 10000 |
    | innodb_use_native_aio | OFF |
    | innodb_use_sys_malloc | ON |
    | innodb_version | 1.1.8 |
    | innodb_write_io_threads | 4 |
    | interactive_timeout | 28800 |
    | join_buffer_size | 131072 |
    | keep_files_on_create | OFF |
    | key_buffer_size | 16777216 |
    | key_cache_age_threshold | 300 |
    | key_cache_block_size | 1024 |
    | key_cache_division_limit | 100 |
    | large_files_support | ON |
    | large_page_size | 0 |
    | large_pages | OFF |
    | lc_messages | en_US |
    | lc_messages_dir | /usr/share/mysql/ |
    | lc_time_names | en_US |
    | license | GPL |
    | local_infile | ON |
    | lock_wait_timeout | 31536000 |
    | locked_in_memory | OFF |
    | log | OFF |
    | log_bin | OFF |
    | log_bin_trust_function_creators | OFF |
    | log_error | |
    | log_output | FILE |
    | log_queries_not_using_indexes | OFF |
    | log_slave_updates | OFF |
    | log_slow_queries | OFF |
    | log_warnings | 1 |
    | long_query_time | 10.000000 |
    | low_priority_updates | OFF |
    | lower_case_file_system | OFF |
    | lower_case_table_names | 0 |
    | max_allowed_packet | 16777216 |
    | max_binlog_cache_size | 18446744073709547520 |
    | max_binlog_size | 1048576 |
    | max_binlog_stmt_cache_size | 18446744073709547520 |
    | max_connect_errors | 10 |
    | max_connections | 151 |
    | max_delayed_threads | 20 |
    | max_error_count | 64 |
    | max_heap_table_size | 16777216 |
    | max_insert_delayed_threads | 20 |
    | max_join_size | 18446744073709551615 |
    | max_length_for_sort_data | 1024 |
    | max_long_data_size | 16777216 |
    | max_prepared_stmt_count | 16382 |
    | max_relay_log_size | 0 |
    | max_seeks_for_key | 18446744073709551615 |
    | max_sort_length | 1024 |
    | max_sp_recursion_depth | 0 |
    | max_tmp_tables | 32 |
    | max_user_connections | 0 |
    | max_write_lock_count | 18446744073709551615 |
    | metadata_locks_cache_size | 1024 |
    | min_examined_row_limit | 0 |
    | multi_range_count | 256 |
    | myisam_data_pointer_size | 6 |
    | myisam_max_sort_file_size | 9223372036853727232 |
    | myisam_mmap_size | 18446744073709551615 |
    | myisam_recover_options | BACKUP |
    | myisam_repair_threads | 1 |
    | myisam_sort_buffer_size | 8388608 |
    | myisam_stats_method | nulls_unequal |
    | myisam_use_mmap | OFF |
    | net_buffer_length | 16384 |
    | net_read_timeout | 30 |
    | net_retry_count | 10 |
    | net_write_timeout | 60 |
    | new | OFF |
    | old | OFF |
    | old_alter_table | OFF |
    | old_passwords | OFF |
    | open_files_limit | 1024 |
    | optimizer_prune_level | 1 |
    | optimizer_search_depth | 62 |
    | optimizer_switch | index_merge=on,index_merge_union=on,index_merge_sort_union=on,index_merge_intersection=on,engine_condition_pushdown=on |
    | performance_schema | OFF |
    | performance_schema_events_waits_history_long_size | 10000 |
    | performance_schema_events_waits_history_size | 10 |
    | performance_schema_max_cond_classes | 80 |
    | performance_schema_max_cond_instances | 1000 |
    | performance_schema_max_file_classes | 50 |
    | performance_schema_max_file_handles | 32768 |
    | performance_schema_max_file_instances | 10000 |
    | performance_schema_max_mutex_classes | 200 |
    | performance_schema_max_mutex_instances | 1000000 |
    | performance_schema_max_rwlock_classes | 30 |
    | performance_schema_max_rwlock_instances | 1000000 |
    | performance_schema_max_table_handles | 100000 |
    | performance_schema_max_table_instances | 50000 |
    | performance_schema_max_thread_classes | 50 |
    | performance_schema_max_thread_instances | 1000 |
    | pid_file | /var/lib/mysql/econlink.pid |
    | plugin_dir | /usr/lib/mysql/plugin/ |
    | port | 3306 |
    | preload_buffer_size | 32768 |
    | profiling | OFF |
    | profiling_history_size | 15 |
    | protocol_version | 10 |
    | query_alloc_block_size | 8192 |
    | query_cache_limit | 1048576 |
    | query_cache_min_res_unit | 4096 |
    | query_cache_size | 16777216 |
    | query_cache_type | ON |
    | query_cache_wlock_invalidate | OFF |
    | query_prealloc_size | 8192 |
    | range_alloc_block_size | 4096 |
    | read_buffer_size | 131072 |
    | read_only | OFF |
    | read_rnd_buffer_size | 262144 |
    | relay_log | |
    | relay_log_index | |
    | relay_log_info_file | relay-log.info |
    | relay_log_purge | ON |
    | relay_log_recovery | OFF |
    | relay_log_space_limit | 0 |
    | report_host | |
    | report_password | |
    | report_port | 3306 |
    | report_user | |
    | rpl_recovery_rank | 0 |
    | secure_auth | OFF |
    | secure_file_priv | |
    | server_id | 0 |
    | skip_external_locking | ON |
    | skip_name_resolve | OFF |
    | skip_networking | OFF |
    | skip_show_database | OFF |
    | slave_compressed_protocol | OFF |
    | slave_exec_mode | STRICT |
    | slave_load_tmpdir | /tmp |
    | slave_net_timeout | 3600 |
    | slave_skip_errors | OFF |
    | slave_transaction_retries | 10 |
    | slave_type_conversions | |
    | slow_launch_time | 2 |
    | slow_query_log | OFF |
    | slow_query_log_file | /var/lib/mysql/econlink-slow.log |
    | socket | /var/run/mysqld/mysqld.sock |
    | sort_buffer_size | 2097152 |
    | sql_auto_is_null | OFF |
    | sql_big_selects | ON |
    | sql_big_tables | OFF |
    | sql_buffer_result | OFF |
    | sql_log_bin | ON |
    | sql_log_off | OFF |
    | sql_low_priority_updates | OFF |
    | sql_max_join_size | 18446744073709551615 |
    | sql_mode | |
    | sql_notes | ON |
    | sql_quote_show_create | ON |
    | sql_safe_updates | OFF |
    | sql_select_limit | 18446744073709551615 |
    | sql_slave_skip_counter | 0 |
    | sql_warnings | OFF |
    | ssl_ca | |
    | ssl_capath | |
    | ssl_cert | |
    | ssl_cipher | |
    | ssl_key | |
    | storage_engine | InnoDB |
    | stored_program_cache | 256 |
    | sync_binlog | 0 |
    | sync_frm | ON |
    | sync_master_info | 0 |
    | sync_relay_log | 0 |
    | sync_relay_log_info | 0 |
    | system_time_zone | UTC |
    | table_definition_cache | 400 |
    | table_open_cache | 400 |
    | thread_cache_size | 8 |
    | thread_concurrency | 10 |
    | thread_handling | one-thread-per-connection |
    | thread_stack | 196608 |
    | time_format | %H:%i:%s |
    | time_zone | SYSTEM |
    | timed_mutexes | OFF |
    | tmp_table_size | 16777216 |
    | tmpdir | /tmp |
    | transaction_alloc_block_size | 8192 |
    | transaction_prealloc_size | 4096 |
    | tx_isolation | REPEATABLE-READ |
    | unique_checks | ON |
    | updatable_views_with_limit | YES |
    | version | 5.5.22-0ubuntu1 |
    | version_comment | (Ubuntu) |
    | version_compile_machine | x86_64 |
    | version_compile_os | debian-linux-gnu |
    | wait_timeout | 28800 |
    +---------------------------------------------------+------------------------------------------------------------------------------------------------------------------------+

  12. #12
    Join Date
    Apr 2000
    Location
    Brisbane, Australia
    Posts
    1,361
    yeah

    Code:
    | have_innodb | YES |
    reports innodb still enabled

    you sure you added the 2 lines i posted under [mysqld] group in my.cnf ?

    Code:
    [mysqld]
    innodb=OFF
    default-storage-engine=MyISAM
    then try mysql stop and start instead of restart

    Code:
    service mysql stop
    service mysql start
    : CentminMod.com Nginx Menu Installer (Nginx 1.9, PHP-FPM 5.3-5.6 & 7.0-dev, MariaDB 5.5/10 + ngx_pagespeed) for CentOS
    : Centmin Mod Community Forums

  13. #13
    Thanks, I was adding the lines just at the end of my.cnf and not under the [mysqld] group . I'm a dumb!

    innodb=OFF
    default-storage-engine=MyISAM
    worked

    Can I send you five bucks to your paypal account as a Thank You for the support? Send me a PM with your paypal address, if this is allowed by this forum rules.

  14. #14
    Join Date
    Apr 2000
    Location
    Brisbane, Australia
    Posts
    1,361
    no need mate (and don't think forum allows it anyway)
    : CentminMod.com Nginx Menu Installer (Nginx 1.9, PHP-FPM 5.3-5.6 & 7.0-dev, MariaDB 5.5/10 + ngx_pagespeed) for CentOS
    : Centmin Mod Community Forums

  15. #15
    Ok! Many thanks anyway

  16. #16
    Join Date
    Jun 2011
    Location
    Woodbridge, NJ
    Posts
    834
    Quote Originally Posted by opaliz View Post
    Thanks, I was adding the lines just at the end of my.cnf and not under the [mysqld] group . I'm a dumb!
    No, you're not dumb. For a long while, nobody said exactly where to put those configuration options in your my.cnf. Any experienced sysadmin knows where those options should be placed without even thinking about it. We often assume that everyone else automatically knows this without realizing that those "learning the ropes" usually does not.

    Glad to hear you got it figured out.

  17. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Similar Threads

  1. Mysql Innodb disabled
    By subin_hutton in forum Hosting Security and Technology
    Replies: 2
    Last Post: 08-02-2010, 09:55 AM
  2. enabling InnoDB in mysql
    By IraqiGeek in forum VPS Hosting
    Replies: 13
    Last Post: 08-24-2009, 11:13 AM
  3. mysql myisam and innodb
    By zelf in forum Hosting Software and Control Panels
    Replies: 2
    Last Post: 02-10-2005, 09:43 PM
  4. Mysql and Innodb
    By Serverplan in forum Hosting Security and Technology
    Replies: 0
    Last Post: 11-24-2003, 09:36 AM
  5. Replication on InnoDB MySQL !!!!
    By ljncb in forum Hosting Security and Technology
    Replies: 2
    Last Post: 06-20-2003, 12:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •