Results 1 to 3 of 3
  1. #1

    yum clean all hangs

    Hi

    When I run yum clean all on my VPS, it says
    Loaded plugins: fastestmirror
    and then nothing happens, i kept the session running for long time, but no change.

    any suggestions?

  2. #2
    Join Date
    Jul 2010
    Location
    ~/
    Posts
    1,312
    Few things spring to mind but most likely to fix it is:

    see if anything has the rpm database locked
    #lsof | grep /var/lib/rpm
    if this gives an output then:
    #kill -9 PID (obviously use the PID number)

    And try again

    if that fails:

    #rm -f /var/lib/rpm/__*
    #rpm --rebuilddb -v -v

    try again.
    -> INCEPTION HOSTING LIMITED
    -> QUALITY XEN & OpenVZ VPS HOSTING
    -> PHOENIX & MIAMI USA & THE NETHERLANDS & UK EU
    -> WHITE LABEL XEN VPS RESELLER PLANS

  3. #3
    Join Date
    Apr 2011
    Location
    Las Vegas, NV
    Posts
    1,627
    Edit the following file.

    /etc/yum/pluginconf.d/fastestmirror.conf

    Change enabled=1 to enabled=0 to disable the fastestmorror plugin. That should fix it. You don't need to restart anything for that change to take effect. Just run yum again.

Similar Threads

  1. Yum hangs/freezes
    By JRPereira in forum Hosting Security and Technology
    Replies: 7
    Last Post: 02-10-2012, 05:07 AM
  2. oops! haha. Ran "yum clean all" and now I broke yum!
    By mouseattack in forum Hosting Security and Technology
    Replies: 10
    Last Post: 04-02-2011, 03:23 PM
  3. CentOS5 VPS - Yum barely working. How to exclude a mirror for YUM?
    By MikeDVB in forum Hosting Security and Technology
    Replies: 5
    Last Post: 04-03-2009, 02:33 AM
  4. YUM - is yum disabled by easyspace
    By SakuiWeb in forum VPS Hosting
    Replies: 7
    Last Post: 10-23-2008, 11:04 PM
  5. yum update hangs on Fedora4
    By petfut in forum Dedicated Server
    Replies: 3
    Last Post: 01-05-2006, 06:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •