Results 1 to 26 of 26
  1. #1
    Join Date
    Aug 2010
    Posts
    80

  2. #2
    Join Date
    Feb 2004
    Location
    UK
    Posts
    1,429
    Hi

    When you installed CSF and LFD, looks like something is gone wrong with the LFD config.

    You could try looking at the config file and seeing if you can see what the issue is.

    Thanks

  3. #3
    Join Date
    Jul 2009
    Location
    Kshatriya
    Posts
    2,725
    It means your lfd is trying to restart on every 5 minute.

    Restart your lfd services from CSF menu or ssh.
    Dewlance® Cheap Windows VPS - Chicago/Orlando/Vegas/AZ - SSD
    WHMCS ReadyMadeKB - Tutorials for cPanel/InterWorx/Softaculous& Growing..
    Super Cheap Annually Shared Hosting - Canada/US/UK

  4. #4
    Join Date
    Aug 2010
    Posts
    80
    Quote Originally Posted by DewlanceHosting View Post
    Restart your lfd services from CSF menu or ssh.
    Just tried restarting lfd through Cpanel and this is what it comes up with

    Restarting lfd...

    Stopping lfd:[FAILED]
    [ OK ]
    Starting lfd:
    Error: You have an unresolved error when starting csf. You need to restart csf successfully before starting lfd
    [ OK ]

    ...Done.

  5. #5
    Join Date
    May 2007
    Posts
    438
    Assuming this is a cpanel server, log into WHM and restart LFD manually. Look for "ConfigServer Security&Firewall" - > Look for:
    "lfd - Login Failure Daemon"

    Then beneath that:
    lfd Restart - Restart lfd

    ... click it and you should get a success message on the following page.

    Edit:
    Bummer, you posted at the same time I did.
    Try this topic for a similar issue: http://www.webhostingtalk.com/showthread.php?t=878332
    or http://forum.configserver.com/viewtopic.php?p=7571

  6. #6
    Join Date
    Aug 2010
    Posts
    80
    Quote Originally Posted by gpl24 View Post
    Assuming this is a cpanel server, log into WHM and restart LFD manually. Look for "ConfigServer Security&Firewall" - > Look for:
    "lfd - Login Failure Daemon"

    Then beneath that:
    lfd Restart - Restart lfd

    ... click it and you should get a success message on the following page.
    Just tried that and it came up with the message that I posted on the previous reply. Then restarted csf and tried restarting lfd again and it says OK now. Will this fix the issue?

  7. #7
    Join Date
    Jul 2009
    Location
    Kshatriya
    Posts
    2,725
    Quote Originally Posted by hostingtube View Post
    Just tried that and it came up with the message that I posted on the previous reply. Then restarted csf and tried restarting lfd again and it says OK now. Will this fix the issue?
    Fixed If your both services are running.
    Dewlance® Cheap Windows VPS - Chicago/Orlando/Vegas/AZ - SSD
    WHMCS ReadyMadeKB - Tutorials for cPanel/InterWorx/Softaculous& Growing..
    Super Cheap Annually Shared Hosting - Canada/US/UK

  8. #8
    Join Date
    Aug 2010
    Posts
    80
    both the processes are running now. Will post an update if I get the error back. Thanks a lot guys!

  9. #9
    Join Date
    Aug 2010
    Posts
    80
    ah! It came back again!! Looks like something is wrong. Can someone please guide me on how to sort this out step by step? I can post any logs that would be helpful to get this fixed.

  10. #10
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Check the /var/log/messages file for deeper analysis. It will give clue why the service is getting restarted unintentionally.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  11. #11
    Join Date
    Jul 2009
    Location
    Kshatriya
    Posts
    2,725
    Yes, and also post this logs:
    /var/log/lfd.log
    /var/log/chkservd.log
    /usr/local/cpanel/logs/error_log

    Your CSF Configuration is correct? (set to default..)
    Dewlance® Cheap Windows VPS - Chicago/Orlando/Vegas/AZ - SSD
    WHMCS ReadyMadeKB - Tutorials for cPanel/InterWorx/Softaculous& Growing..
    Super Cheap Annually Shared Hosting - Canada/US/UK

  12. #12
    Join Date
    Aug 2010
    Posts
    80
    Quote Originally Posted by david510 View Post
    Check the /var/log/messages file for deeper analysis. It will give clue why the service is getting restarted unintentionally.
    Thanks I'll post it.

  13. #13
    Join Date
    Aug 2010
    Posts
    80

    Thumbs up

    Quote Originally Posted by DewlanceHosting View Post
    Your CSF Configuration is correct? (set to default..)
    I assume everything is alright as I've not changed any settings after installing CSF. I'm posting the logs. Thanks a lot for your help


    #############################
    File: /var/log/chkservd.log
    #############################

    Service Check Started
    Loading services ...Done
    [2011-04-06 18:36:01 -0400] Service check ....Done
    Service Check Finished
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Chkservd is currently suspended, waiting 100 seconds
    Service Check Started
    Loading services .....cpanellogd....cpsrvd....exim....httpd....imap....mysql...$
    [2011-04-06 19:04:51 -0400] Service check ....syslogd [[check command:+][tcp co$
    Service Check Finished
    Service Check Started
    Loading services .....cpanellogd....cpsrvd....exim....httpd....imap....mysql...$
    [2011-04-06 19:09:52 -0400] Service check ....syslogd [[check command:+][tcp co$
    Service Check Finished


    ######################################
    File: /usr/local/cpanel/logs/error_log
    ######################################

    [2011-05-14 04:57:13 -0400] info [quotacheck] Quota checks and notifications disabled for mail accounts and disk usage per Tweak Settings
    [2011-05-14 04:57:37 -0400] warn [whostmgr2] Failed to download Addon whm version file at whostmgr/bin/whostmgr2 line 2864
    main::getaddonversions('whm') called at whostmgr/bin/whostmgr2 line 2899
    main::updateaddons() called at whostmgr/bin/whostmgr2 line 276
    Building global cache for cpanel...Done
    [2011-05-15 04:57:16 -0400] info [quotacheck] Quota checks and notifications disabled for mail accounts and disk usage per Tweak Settings
    [2011-05-15 04:57:44 -0400] warn [whostmgr2] Failed to download Addon whm version file at whostmgr/bin/whostmgr2 line 2864
    main::getaddonversions('whm') called at whostmgr/bin/whostmgr2 line 2899
    main::updateaddons() called at whostmgr/bin/whostmgr2 line 276
    Building global cache for cpanel...Done
    [2011-05-16 04:57:09 -0400] info [quotacheck] Quota checks and notifications disabled for mail accounts and disk usage per Tweak Settings
    [2011-05-16 04:57:28 -0400] warn [whostmgr2] Failed to download Addon whm version file at whostmgr/bin/whostmgr2 line 2864
    main::getaddonversions('whm') called at whostmgr/bin/whostmgr2 line 2899
    main::updateaddons() called at whostmgr/bin/whostmgr2 line 276


    #######################
    File: /var/log/messages
    #######################

    May 15 04:02:02 earth syslogd 1.4.1: restart.
    May 15 04:43:41 earth ntpd[2952]: kernel time sync enabled 4001
    May 15 05:00:46 earth ntpd[2952]: synchronized to 74.118.152.85, stratum 2
    May 15 05:01:24 earth ntpd[2952]: synchronized to 173.246.103.93, stratum 3
    May 15 05:01:37 earth ntpd[2952]: synchronized to LOCAL(0), stratum 10
    May 15 05:01:37 earth ntpd[2952]: kernel time sync enabled 0001
    May 15 05:17:50 earth ntpd[2952]: synchronized to 38.108.104.170, stratum 2
    May 15 05:51:59 earth ntpd[2952]: time reset +0.993092 s
    May 15 05:51:59 earth ntpd[2952]: kernel time sync enabled 4001
    May 15 05:55:17 earth ntpd[2952]: synchronized to LOCAL(0), stratum 10
    May 15 05:55:17 earth ntpd[2952]: kernel time sync enabled 0001
    May 15 05:56:42 earth ntpd[2952]: synchronized to 74.118.152.85, stratum 2
    May 15 06:12:24 earth ntpd[2952]: synchronized to 38.108.104.170, stratum 2
    May 15 06:40:22 earth ntpd[2952]: synchronized to 74.118.152.85, stratum 2
    May 15 06:49:02 earth ntpd[2952]: synchronized to 38.108.104.170, stratum 2
    May 15 08:26:45 earth ntpd[2952]: synchronized to 74.118.152.85, stratum 2
    May 15 08:52:47 earth ntpd[2952]: synchronized to 38.108.104.170, stratum 2
    May 15 09:43:34 earth ntpd[2952]: kernel time sync enabled 4001
    May 15 10:00:37 earth ntpd[2952]: kernel time sync enabled 0001
    May 15 10:16:44 earth dhclient: DHCPREQUEST on eth0 to 72.14.180.142 port 67
    May 15 10:16:44 earth dhclient: DHCPACK from 72.14.180.142
    May 15 10:16:44 earth dhclient: bound to 66.228.49.16 -- renewal in 33545 seconds.
    May 15 10:34:46 earth ntpd[2952]: kernel time sync enabled 4001
    May 15 10:51:50 earth ntpd[2952]: kernel time sync enabled 0001
    May 15 12:17:14 earth ntpd[2952]: kernel time sync enabled 4001
    May 15 14:16:41 earth ntpd[2952]: kernel time sync enabled 0001


  14. #14
    Join Date
    Aug 2010
    Posts
    80
    Do I need to post any more logs? I'm lost and in need of some great help

  15. #15
    Join Date
    May 2011
    Location
    N/A
    Posts
    116
    Under WHM > Contact Manager put correct contact manager.

    Then restart the CSF -d / -e from SSH/WHM directly.

  16. #16
    Join Date
    Aug 2010
    Posts
    80

    Thumbs up

    Quote Originally Posted by stardust_x7 View Post
    Under WHM > Contact Manager put correct contact manager.

    Then restart the CSF -d / -e from SSH/WHM directly.
    Just restarted csf by csf -r and it's working fine for the past 10 minutes. I fear this would come back as it did the same last time too. thanks for your help.

  17. #17
    Join Date
    Aug 2010
    Posts
    80

  18. #18
    Join Date
    Aug 2010
    Posts
    80

    Unhappy

    Quote Originally Posted by hostingtube View Post
    Well, it's back again!
    any clue?
    I would appreciate if someone can help me straighten this out.

  19. #19
    Join Date
    Feb 2004
    Location
    UK
    Posts
    1,429
    Hi

    Why not contact the forums on configserver.com where you downloaded the script from ?

    Thanks

  20. #20
    Join Date
    Aug 2010
    Posts
    80
    Quote Originally Posted by abtme View Post
    Hi

    Why not contact the forums on configserver.com where you downloaded the script from ?

    Thanks
    makes sense! will give that a try and post the updates.

  21. #21
    Join Date
    May 2005
    Location
    New York
    Posts
    736
    Try changing your portflood setting in the CSF configuration to disabled - recent update to CentOS caused issues with that setting on one of our servers.
    Perigee Global Corporation
    Design, Development and Hosting Solutions
    Dedicated Servers, CDN, Hosted E-Mail, Web Hosting, VPS & Cloud Servers
    1.212.400-7632 www.perigeeglobal.com

  22. #22
    Join Date
    Jul 2009
    Location
    Kshatriya
    Posts
    2,725

    Talking

    Open a support ticket with cPanel and they'll fix your problem within 5 - 10 minute
    Dewlance® Cheap Windows VPS - Chicago/Orlando/Vegas/AZ - SSD
    WHMCS ReadyMadeKB - Tutorials for cPanel/InterWorx/Softaculous& Growing..
    Super Cheap Annually Shared Hosting - Canada/US/UK

  23. #23
    Join Date
    Oct 2010
    Location
    ON, Canada
    Posts
    960
    What is the output of "perl /etc/csf/csftest.pl"?
    GG Web Hosting
    Backup, Digital (SSL) Certificates, Domains, Hosting, Privacy Policy, Software
    S/W: Peel Ads, Softaculous, WHMCS Addons (Abuse Mon., Affiliate Peel Ads, Client Stat., Ord. Prevention, Ord. Stat., Softaculous NOC, Sys. Cleanup)
    Authorized Reseller Program

  24. #24
    Join Date
    Aug 2010
    Posts
    80
    Quote Originally Posted by jNive View Post
    Try changing your portflood setting in the CSF configuration to disabled - recent update to CentOS caused issues with that setting on one of our servers.
    I'll try that. thanks

  25. #25
    Join Date
    Aug 2010
    Posts
    80

    Thumbs up

    Quote Originally Posted by GGWH-James View Post
    What is the output of "perl /etc/csf/csftest.pl"?
    This is the output.

    Testing ip_tables/iptable_filter...OK
    Testing ipt_LOG...OK
    Testing ipt_multiport/xt_multiport...OK
    Testing ipt_REJECT...OK
    Testing ipt_state/xt_state...OK
    Testing ipt_limit/xt_limit...OK
    Testing ipt_recent...OK
    Testing ipt_owner/xt_owner...FAILED [Error: iptables: Unknown error 18446744073709551615] - Required for SMTP_BLOCK and UID/GID blocking features
    Testing iptable_nat/ipt_REDIRECT...OK

    RESULT: csf will function on this server but some features will not work due to some missing iptables modules [1]

  26. #26
    Join Date
    Aug 2010
    Posts
    80

    Smile

    Quote Originally Posted by DewlanceHosting View Post
    Open a support ticket with cPanel and they'll fix your problem within 5 - 10 minute
    I was curious to know what was causing it

Similar Threads

  1. lfd failed
    By Saryooo in forum Hosting Security and Technology
    Replies: 7
    Last Post: 03-24-2014, 05:40 AM
  2. lfd failed
    By Saryooo in forum Hosting Security and Technology
    Replies: 1
    Last Post: 09-02-2009, 01:36 PM
  3. lfd failed help me
    By mixmox in forum Hosting Security and Technology
    Replies: 2
    Last Post: 05-05-2009, 12:00 PM
  4. Replies: 29
    Last Post: 04-03-2002, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •