Results 1 to 9 of 9
  1. #1

    problem HyperVM Install

    [[email protected] ~]# sh ./hypervm-install-master.sh --virtualization-type=openvz
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.ubiquityservers.com
    * extras: mirror.steadfast.net
    * updates: mirrors.serveraxis.net
    Setting up Install Process
    Package php-5.2.17-1.x86_64 already installed and latest version
    Package wget-1.11.4-2.el5_4.1.x86_64 already installed and latest version
    Package zip-2.31-2.el5.x86_64 already installed and latest version
    Package unzip-5.52-3.el5.x86_64 already installed and latest version
    Nothing to do
    --2011-05-12 19:08:46-- http://download.lxlabs.com/download/program-install.zip
    Resolving download.lxlabs.com... 66.197.145.24
    Connecting to download.lxlabs.com|66.197.145.24|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 68091 (66K) [application/zip]
    Saving to: `program-install.zip'

    100%[==============================================================================================================================>] 68,091 --.-K/s in 0.1s

    2011-05-12 19:08:46 (502 KB/s) - `program-install.zip' saved [68091/68091]

    groupadd: group lxlabs exists
    useradd: user lxlabs exists
    Installing packages which lxlighttpd zip unzip lxphp lxzend curl mysql mysql-server mysqlclient10...
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.ubiquityservers.com
    * extras: mirror.steadfast.net
    * updates: mirrors.serveraxis.net
    Setting up Install Process
    Package which-2.16-7.x86_64 already installed and latest version
    Package lxlighttpd-1.4.26-2.x86_64 already installed and latest version
    Package zip-2.31-2.el5.x86_64 already installed and latest version
    Package unzip-5.52-3.el5.x86_64 already installed and latest version
    Package lxphp-5.2.1-400.i386 already installed and latest version
    Package lxzend-3.3-100lxa.i386 already installed and latest version
    Package curl-7.15.5-9.el5_6.2.x86_64 already installed and latest version
    Package curl-7.15.5-9.el5_6.2.i386 already installed and latest version
    Package mysql-5.0.92-lxcenter.1.x86_64 already installed and latest version
    Package mysql-5.0.77-4.el5_6.6.i386 already installed and latest version
    Package mysql-server-5.0.92-lxcenter.1.x86_64 already installed and latest version
    No package mysqlclient10 available.
    Nothing to do
    Stopping MySQL: [FAILED]
    Timeout error occurred trying to start MySQL Daemon.
    Starting MySQL: [FAILED]
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Fatal Error: Could not connect to Mysql Localhost using user root and password ""
    If this is a brand new install, you can completely remove mysql by running the commands below
    rm -rf /var/lib/mysql
    rpm -e mysql-server
    And then run the installer again
    [[email protected] ~]#

  2. #2
    Join Date
    Sep 2008
    Location
    Dallas, TX
    Posts
    4,552
    Did you try...
    rm -rf /var/lib/mysql
    rpm -e mysql-server


    Then run the installer again?
    Jacob Wall - GetCloak.com

  3. #3
    [[email protected] ~]# rm -rf /var/lib/mysql
    [[email protected] ~]# rpm -e mysql-server
    [[email protected] ~]# sh ./hypervm-install-master.sh --virtualization-type=openvz
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.ubiquityservers.com
    * extras: mirror.steadfast.net
    * updates: mirrors.serveraxis.net
    Setting up Install Process
    Package php-5.2.17-1.x86_64 already installed and latest version
    Package wget-1.11.4-2.el5_4.1.x86_64 already installed and latest version
    Package zip-2.31-2.el5.x86_64 already installed and latest version
    Package unzip-5.52-3.el5.x86_64 already installed and latest version
    Nothing to do
    --2011-05-12 19:17:38-- http://download.lxlabs.com/download/program-install.zip
    Resolving download.lxlabs.com... 66.197.145.24
    Connecting to download.lxlabs.com|66.197.145.24|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 68091 (66K) [application/zip]
    Saving to: `program-install.zip'

    100%[==============================================================================================================================>] 68,091 --.-K/s in 0.1s

    2011-05-12 19:17:38 (584 KB/s) - `program-install.zip' saved [68091/68091]

    groupadd: group lxlabs exists
    useradd: user lxlabs exists
    Installing packages which lxlighttpd zip unzip lxphp lxzend curl mysql mysql-server mysqlclient10...
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.ubiquityservers.com
    * extras: mirror.steadfast.net
    * updates: mirrors.serveraxis.net
    Setting up Install Process
    Package which-2.16-7.x86_64 already installed and latest version
    Package lxlighttpd-1.4.26-2.x86_64 already installed and latest version
    Package zip-2.31-2.el5.x86_64 already installed and latest version
    Package unzip-5.52-3.el5.x86_64 already installed and latest version
    Package lxphp-5.2.1-400.i386 already installed and latest version
    Package lxzend-3.3-100lxa.i386 already installed and latest version
    Package curl-7.15.5-9.el5_6.2.x86_64 already installed and latest version
    Package curl-7.15.5-9.el5_6.2.i386 already installed and latest version
    Package mysql-5.0.92-lxcenter.1.x86_64 already installed and latest version
    Package mysql-5.0.77-4.el5_6.6.i386 already installed and latest version
    No package mysqlclient10 available.
    Resolving Dependencies
    --> Running transaction check
    ---> Package mysql-server.x86_64 0:5.0.92-lxcenter.1 set to be updated
    --> Finished Dependency Resolution

    Dependencies Resolved

    ================================================================================
    Package Arch Version Repository Size
    ================================================================================
    Installing:
    mysql-server x86_64 5.0.92-lxcenter.1 lxlabsupdate 10 M

    Transaction Summary
    ================================================================================
    Install 1 Package(s)
    Upgrade 0 Package(s)

    Total download size: 10 M
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing : mysql-server 1/1

    Installed:
    mysql-server.x86_64 0:5.0.92-lxcenter.1

    Complete!
    Stopping MySQL: [FAILED]
    Initializing MySQL database: Installing MySQL system tables...
    110512 19:17:44 [ERROR] Error message file '/usr/share/mysql/english/errmsg.sys' had only 480 error messages,
    but it should contain at least 481 error messages.
    Check that the above file is the right version for this program!
    110512 19:17:44 [ERROR] Aborting

    Installation of system tables failed!

    Examine the logs in /var/lib/mysql for more information.
    You can try to start the mysqld daemon with:
    /usr/libexec/mysqld --skip-grant &
    and use the command line tool
    /usr/bin/mysql to connect to the mysql
    database and look at the grant tables:

    shell> /usr/bin/mysql -u root mysql
    mysql> show tables

    Try 'mysqld --help' if you have problems with paths. Using --log
    gives you a log in /var/lib/mysql that may be helpful.

    The latest information about MySQL is available on the web at
    http://www.mysql.com
    Please consult the MySQL manual section: 'Problems running mysql_install_db',
    and the manual section that describes problems on your OS.
    Another information source is the MySQL email archive.
    Please check all of the above before mailing us!
    And if you do mail us, you MUST use the /usr/bin/mysqlbug script!
    [FAILED]
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Fatal Error: Could not connect to Mysql Localhost using user root and password ""
    If this is a brand new install, you can completely remove mysql by running the commands below
    rm -rf /var/lib/mysql
    rpm -e mysql-server
    And then run the installer again

    Same problem

  4. #4
    Join Date
    Feb 2004
    Location
    Atlanta, GA
    Posts
    5,627
    turn off SELinux

  5. #5
    SELINUX=disabled

    I am still the same problem

  6. #6
    Is there a solution?

  7. #7
    Join Date
    May 2004
    Location
    Toronto, Canada
    Posts
    5,084
    You will get better answers from the lxcenter.org forum for this. http://forum.lxcenter.org/
    André Allen | E: aallen(a)linovus.ca
    Linovus Holdings Inc
    Shared Hosting, Reseller Hosting, VPS, Dedicated Servers & Public Cloud | USA, Canada & UK - 24x7x365 Support

  8. #8

    Same problem

    Hello, I have the same problem too.
    My situation is:
    Dedicated server
    OS Centos 5.6 x86_64 - fresh minimal installation.

    I tried several solutions found on various forums, but the problem persists and I always get the exact same error of "cornervps".
    SELINUX is disabled and as suggested on the LXCenter Forum I tried this command:

    Code:
    rpm -aq | grep mysql | xargs rpm -e --nodeps --allmatches
    yum install mysql mysql-server
    But nothing....With the same OS 32 bit version all works fine, but I need a 64 bit environment.

    I hope someone is able to help....

  9. #9

    SOLVED

    Ok guys, I finally found a solution.
    The problem is caused by the last relase of mysql from lxcenter repo. So, starting with a fresh CentOS 5.6 x86_64 minimal installation, you have to create the file file "/etc/yum.repos.d/lxlabs.repo" and edit in this way:
    Code:
    #additional packages that may be useful
    [lxlabsupdate]
    name=centos-5-$releasever - lxlabsupdates
    baseurl=(I can't post the link because I'm not allowed)
    gpgcheck=0
    enabled=1
    exclude=mysql*
    
    #packages used/produced in the build but not released
    [lxlabslxupdate]
    name=centos-5-$releasever - lxlabslxupdates
    baseurl=(I can't post the link because I'm not allowed)
    gpgcheck=0
    enabled=1
    exclude=mysql*
    Then save the changes and, in order to prevent alteration from the hypervm's installation script, run the command:
    Code:
    chattr +i /etc/yum.repos.d/lxlabs.repo
    Now you can run the installation and all should work fine!!!

Similar Threads

  1. need install hypervm with openvz
    By herotom in forum Dedicated Server
    Replies: 2
    Last Post: 12-11-2009, 07:30 PM
  2. how install HyperVM?
    By hichkas in forum Hosting Software and Control Panels
    Replies: 26
    Last Post: 07-27-2009, 04:25 PM
  3. How to install HyperVM
    By sinus in forum Hosting Security and Technology
    Replies: 3
    Last Post: 12-15-2008, 10:01 PM
  4. Problem with installing HyperVM on CentOS (Problem w/ YUM?)
    By DennisM in forum Hosting Security and Technology
    Replies: 4
    Last Post: 11-05-2007, 09:05 PM
  5. Install and configure OpenVZ and HyperVM
    By Oskare100 in forum Employment / Job Offers
    Replies: 7
    Last Post: 10-10-2006, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •