Results 1 to 6 of 6
  1. #1

    Unhappy Odd cPanel Error - Possibly permit related.


    I am experiencing this really strange problem on one of our cPanel servers. We have one user who has made an add-on domain and they have sites in the root directory of the new domain, all works fine, but any subfolders won't open giving a "Not Found" error. Although 3 folders will, very odd. I have used chown to change the subfolders and subfiles to the right user account for the user and used chmod to make sure the permissions are correct. I have also tried removing the domain, re-adding the domain, removing all files and re uploading via FTP, but still the same issue. I have also checked .htaccess but there isn't any rules in the .htaccess file. The server isn't under any real load (0.04 average) and plenty of RAM is available, cPanel is LATEST STABLE. Only seem to have this issue with this one account and this one addon domain, the other addons on the account are working fine.

    Here is the directory listing with permits and owner shown... I have gained permission to show this from the user...

    [email protected] [/home/ljones/public_html/]# ls -l
    total 60
    drwxr-xr-x 10 ljones ljones 4096 May 12 21:45 ./
    drwxr-xr-x 10 ljones nobody 4096 May 12 21:29 ../
    drwxr-xr-x 2 ljones ljones 4096 May 12 21:29 cgi-bin/
    drwxr-xr-x 2 ljones ljones 4096 Jan 17 18:52 css/
    drwxr-xr-x 2 ljones ljones 4096 Jan 11 00:43 ed1/
    drwxr-xr-x 2 ljones ljones 4096 May 12 17:23 ed2/
    drwxr-xr-x 2 ljones ljones 4096 Apr 4 01:32 img/
    drwxr-xr-x 2 ljones ljones 4096 Jan 17 02:23 inc/
    -rw-r--r-- 1 ljones ljones 13536 Apr 7 19:26 index.html
    drwxr-xr-x 2 ljones ljones 4096 May 12 21:43 LATEST/
    drwxr-xr-x 2 ljones ljones 4096 Apr 4 14:45 podcast/
    -rw-r--r-- 1 ljones ljones 911 Feb 14 15:43 sie.html
    The "podcast", "inc" and "css" folders gives a directory listing as expected, the other folders "ed1", "ed2" and "LATEST" give "Not Found" error pages.

    Really very odd, I have been in contact with cPanel but no joy yet, wondered if you guys had any ideas I could try out to fix the issue.

    Kind Regards


  2. #2
    Join Date
    May 2011
    Run this :


  3. #3
    After you run that, run this:
    service httpd restart

  4. #4

    I have just tried rebuilding the Apache configuration using the script, and I've restarted the service. No errors upon restart but still not working as expected. Interesting that none of these "Not Found" errors are showing up in the Apache logs.

    Really not sure what is causing this.

    Thanks for your help so far!

    Kind Regards


  5. #5
    Join Date
    May 2004
    Did you change the IP/server/nameserver of the addon domain lately ? I am thinking in the lines of DNS cache. Did you check whether the domain logs have the entry for the URL hits ? Whats is inside ed1 and other directories having issues ? Is there a .htaccess or any redirection set ?

    ▁▂▄▅▆▇█SupportSages█▇▆▅▄▂▁ - Bytes of Wisdom @ Work
    24/7 Support with 15 mins response time & no charge guarantees

  6. #6

    Just done a DNS trace, looks like the client is using the wrong Nameservers! Duh can't believe I didn't check this, oh well, lesson learnt and problem solved.

    Thanks for your help guys.


Similar Threads

  1. possible virus spreading *possibly related to cpanel exploit*
    By DeltaAnime in forum Dedicated Server
    Replies: 0
    Last Post: 10-02-2006, 06:04 PM
  2. Odd Script Error
    By Jouninshinobi in forum Programming Discussion
    Replies: 3
    Last Post: 03-31-2005, 08:49 AM
  3. odd apache error
    By jaymef in forum Hosting Security and Technology
    Replies: 3
    Last Post: 03-30-2005, 03:04 AM
  4. Hosting Related Forum Possibly up for Sale
    By ExtremeIS in forum Other Offers & Requests
    Replies: 3
    Last Post: 06-13-2004, 10:45 PM
  5. Odd Cookie Error
    By Falco1199 in forum Programming Discussion
    Replies: 8
    Last Post: 03-09-2003, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts