Results 1 to 16 of 16

Thread: Index Problem

  1. #1
    Join Date
    Apr 2011
    Posts
    74

    Index Problem

    I have a Kloxo CentOS 32 bit vps. When I point my domain to the vps ip address it is not loading the index.php page. It just shows a blank white page. When I shut down the VPS, my browser says this page cannot be displayed. So I know that the domain is pointed towards the VPS. How can I fix this?

  2. #2
    Did you check your Apache error log?

  3. #3
    Join Date
    Apr 2011
    Posts
    74
    I am not running Apache. I am running lighttpd.

  4. #4
    Join Date
    May 2008
    Location
    Texas
    Posts
    188
    Be sure to check your error log.

    Are you accessing the page with /index.php trailing your IP address? Are you sure you don't have a blank index.html uploaded as well?

  5. #5
    Join Date
    Apr 2011
    Posts
    74
    I am accessing the page from the actual domain. My error log is completely empty. I am positive I do not have a blank html file.

  6. #6
    Join Date
    Jul 2009
    Location
    The backplane
    Posts
    1,790
    Will it serve up a regular index.html file?

  7. #7
    Join Date
    Apr 2011
    Posts
    74
    No, now instead of a blank page 403 - Forbidden comes up. I have all of my permissions set to 755.

  8. #8
    Join Date
    Apr 2011
    Posts
    74
    After switching to Apache it is now giving me a 403 error.

    Here is my error log:

    [Tue May 03 08:15:58 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:16:00 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:16:04 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:16:27 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:18:08 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:18:20 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:18:21 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:19:43 2011] [error] [client 68.2.83.202] (13)Permission denied: access to / denied
    [Tue May 03 08:19:49 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:56 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:56 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:57 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:57 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:59 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied
    [Tue May 03 08:19:59 2011] [error] [client 68.2.83.202] (13)Permission denied: access to /index.php denied

  9. #9
    Join Date
    Jul 2009
    Location
    The backplane
    Posts
    1,790
    Is the document root somewhere under /home?

  10. #10
    Join Date
    Apr 2011
    Posts
    74
    Full root is: /home/allerfamily/allerfamily.net/index.php

  11. #11
    Join Date
    Dec 2007
    Posts
    471
    What are the permissions and owners on /home/allerfamily/allerfamily.net ?

  12. #12
    Join Date
    Jul 2009
    Location
    The backplane
    Posts
    1,790
    CentOS puts very restrictive permissions on home directories, try chmod 755 /home/allerfamily. the allerfamily.net subdirectory should be fine unless you changed the permissions manually.

  13. #13
    Join Date
    Jan 2011
    Location
    India
    Posts
    1,446
    TRY TO UPLOAD YOUR INDEX FILES AGAIN AND REPLACE THE PREVIOUS ONE YOUR PROBLEM WILL SURELY BE SOLVED

  14. #14
    Join Date
    Apr 2011
    Posts
    74
    All Permissions are set to 755. Re-uploading the index file does no good.

  15. #15
    Join Date
    Jun 2003
    Location
    California
    Posts
    2,766
    "index.php" is not always enabled as a valid index file. Have you tried a "index.html" file in the same webspace?

    I'm not sure where the lighttpd configuration file is but I think you can see the configuration by using "lighttpd -p" from the command line. Look for the "server.indexfiles" entry. If "index.php" doesn't appear there it won't display.

  16. #16
    Join Date
    Jul 2009
    Location
    The backplane
    Posts
    1,790
    Quote Originally Posted by jodoloy View Post
    All Permissions are set to 755. Re-uploading the index file does no good.
    Can you post or PM me your lighttpd config file?

Similar Threads

  1. Script to copy all index.htm index.html index.php from all users
    By WhiteBear in forum Hosting Security and Technology
    Replies: 2
    Last Post: 06-29-2010, 12:41 PM
  2. ie z-index problem
    By dnout in forum Web Design and Content
    Replies: 1
    Last Post: 12-14-2008, 10:55 PM
  3. Problem With Index Pages
    By NotoriousKIM in forum Hosting Security and Technology
    Replies: 3
    Last Post: 10-16-2004, 05:37 PM
  4. Firebird Index Problem
    By cortices in forum Hosting Security and Technology
    Replies: 0
    Last Post: 08-31-2003, 01:35 PM
  5. index.htm and index.html - how to solve this problem??? Help
    By AvailableHost in forum Programming Discussion
    Replies: 2
    Last Post: 06-17-2003, 04:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •