Results 1 to 3 of 3
  1. #1

    VPS Concurrent DSO patch help

    I have DSO handling PHP5 and SUPHP handling PHP4. I'm on a VPS with cpanel. So in easyapache, Concurrent DSO patch is enabled on php4 and disabled on php5 (under Exhaustive Options List). Can I remove Concurrent DSO patch off of php4? Is it even needed with my configuration. Will it cause issues with my clients (I webhost)?

    Sorry I've been up for a while, so if something doesn't make sense feel free to ask me what the hell im talking about



    Default PHP Version (.php files) 5
    PHP 5 Handler dso
    PHP 4 Handler suphp

    Apache suEXEC on

  2. #2
    Join Date
    Apr 2009
    Location
    inside wht
    Posts
    716
    dso and suphp together running same server is not a good idea. Probably there will be no php4 users in your server. If so just disable it.

    # /usr/local/cpanel/bin/rebuild_phpconf 5 none dso 1
    24x7 PRO-ACTIVE SERVER MANAGEMENT | OUTSOURCED WEB HOSTING SUPPORT
    Now Available The first Support Brand for Startup Hosting Companies

    Sales : sales @ syslint.com | Skype us : SyslintSkype | Call us : (+91)6007799

  3. #3
    So Concurrent DSO patch allows php4 and php5 to be used simultaneously? And if I disable it, that means I'd have to pick PHP5 as my primary and only?

Similar Threads

  1. Vps optimization & Apache suphp, dso vs fcgi
    By adeministrator in forum Hosting Security and Technology
    Replies: 11
    Last Post: 04-05-2010, 02:46 AM
  2. How Many Concurrent Users on the average VPS Plan
    By Worthen in forum VPS Hosting
    Replies: 2
    Last Post: 07-28-2008, 07:08 AM
  3. Replies: 28
    Last Post: 01-30-2007, 11:22 AM
  4. Replies: 0
    Last Post: 01-22-2007, 06:35 PM
  5. DSO in apache
    By EddieFudd in forum Hosting Security and Technology
    Replies: 0
    Last Post: 06-11-2006, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •