Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2005

    Strange "/usr/bin/mysql_client_test" hash change

    I just had one strange case of modified /usr/bin/mysql_client_test file.

    We have received a LFD notification about file modification.

    I checked the file and modify/change stamp was not changed and file size was not changed. I then compared md5 hash with other servers with the same "MySQL-test" version and md5 hash was really different on that server. I can't find anything other strange on that server beside that. I tried to look into a binary file at the begining and at the end of file and it was identical like the same binary on other servers.

    Now even more strange thing is that few hours later new LFD notification about the same file is received. I again checked and comapared md5 hash with other servers and now md5 again match with all other servers, so file is somehow restored to original again...

    Does anyone have some explanation for this? Is it maybe possible that some filesistem corruption was the cause of file difference and then maybe some sector relocation fixed it later. I also have to mention that this is a hardware RAID-1 array.

  2. #2
    Join Date
    Apr 2009
    FS corruption fact should be seen in the system log files, did you check them? Please specify hardware used by this system.
    █▌KVM-based SSD VPS
    ▌Unmetered Dedicated Servers
    ▌Colocation at 100 Delawanna Ave, Clifton, NJ

  3. #3
    Join Date
    Mar 2005
    I forgot to mention that server is actually a OpenVZ container.

    Nothing in the system log files in the VPS or at the hardware node.

    Server is Intel i7 920, with 2 x 750 GB hard drives in hardware RAID-1 (3ware Inc 9650SE SATA-II RAID PCIe)

    I have just checked SMART details and found this on one hard drive...

    5 Reallocated_Sector_Ct 0x0033 097 097 010 Pre-fail Always - 80
    187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 33
    196 Reallocated_Event_Count 0x0032 098 098 000 Old_age Always - 80
    200 Multi_Zone_Error_Rate 0x000a 100 099 000 Old_age Always - 59

    ... so is it possible that this is the reason? It's still very strange, RAID controller should not expose wrong data in case of one drive have corruption...

Similar Threads

  1. GET form - Change "?" to "&"
    By M_R_W in forum Programming Discussion
    Replies: 6
    Last Post: 06-28-2010, 12:39 PM
  2. proc list only shows "/usr/bin/php" - no more file names???
    By papi in forum Hosting Security and Technology
    Replies: 3
    Last Post: 01-09-2008, 12:09 AM
  3. want to change default folder from "\" to "\www" - Plz help me
    By looking4hosting in forum Hosting Security and Technology
    Replies: 2
    Last Post: 02-24-2005, 07:37 AM
  4. Modernbill: Change From "WorldPay" to "Credit Card" on checkout.php as Payment O
    By A|J in forum Hosting Software and Control Panels
    Replies: 2
    Last Post: 10-06-2004, 03:38 PM
  5. Difference between "change IP" and "edit DNS"
    By safu in forum Web Hosting
    Replies: 0
    Last Post: 10-08-2001, 10:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts