Results 1 to 5 of 5

Thread: Server Lagging

  1. #1
    Join Date
    Apr 2008
    Location
    England
    Posts
    516

    Server Lagging

    I have a problem with a server that seems to be running very slow all I can find in the logs that could be related is below.

    Any help is appreciated

    Code:
    Mar 19 01:47:59 ns380846 kernel: ata1: link is slow to respond, please be patient (ready=0)
    Mar 19 01:48:04 ns380846 kernel: ata1: device not ready (errno=-16), forcing hardreset
    Mar 19 01:48:04 ns380846 kernel: ata1: soft resetting link
    Mar 19 01:48:09 ns380846 kernel: ata1: link is slow to respond, please be patient (ready=0)
    Mar 19 01:48:14 ns380846 kernel: ata1: soft resetting link
    Mar 19 01:48:19 ns380846 kernel: ata1: link is slow to respond, please be patient (ready=0)
    Mar 19 01:48:22 ns380846 kernel: ata1.00: configured for UDMA/100
    Mar 19 01:48:22 ns380846 kernel: ata1.00: device reported invalid CHS sector 0
    Mar 19 01:48:22 ns380846 kernel: ata1: EH complete

  2. #2
    Join Date
    Nov 2010
    Location
    Arizona
    Posts
    297
    Is this Ubuntu?

  3. #3
    Join Date
    Apr 2008
    Location
    England
    Posts
    516
    Yes, ubuntu 10.10

  4. #4
    Join Date
    Nov 2010
    Location
    Arizona
    Posts
    297
    This looks like a bug:

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/285892

    you might need an upgrade.

  5. #5
    Join Date
    Apr 2008
    Location
    England
    Posts
    516
    I tried a different kernel but the problem still exsists.

    When the system is idle disk io is at 50%, but when I go to io top no processes appear to be causing high disk io.

    Code:
    top - 19:43:43 up  2:41,  3 users,  load average: 4.69, 4.03, 3.13
    Tasks: 112 total,   1 running, 101 sleeping,  10 stopped,   0 zombie
    Cpu(s):  0.0%us,  0.0%sy,  0.0%ni, 14.1%id, 85.9%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:   4008008k total,  1023944k used,  2984064k free,   758312k buffers
    Swap:  2095096k total,        0k used,  2095096k free,    60016k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
        1 root      20   0 23768 1904 1296 S    0  0.0   0:00.89 init
        2 root      20   0     0    0    0 S    0  0.0   0:00.00 kthreadd
        3 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0
        4 root      20   0     0    0    0 S    0  0.0   0:00.00 ksoftirqd/0
        5 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1
        6 root      20   0     0    0    0 S    0  0.0   0:00.00 ksoftirqd/1
        7 root      20   0     0    0    0 S    0  0.0   0:00.07 events/0
        8 root      20   0     0    0    0 S    0  0.0   0:00.16 events/1
        9 root      20   0     0    0    0 S    0  0.0   0:00.00 cpuset
       10 root      20   0     0    0    0 S    0  0.0   0:00.01 khelper
       13 root      20   0     0    0    0 S    0  0.0   0:00.00 netns
       16 root      20   0     0    0    0 S    0  0.0   0:00.00 async/mgr
      259 root      20   0     0    0    0 S    0  0.0   0:00.00 sync_supers
      261 root      20   0     0    0    0 S    0  0.0   0:00.00 bdi-default
      262 root      20   0     0    0    0 S    0  0.0   0:00.00 kintegrityd/0
      263 root      20   0     0    0    0 S    0  0.0   0:00.00 kintegrityd/1
      265 root      20   0     0    0    0 S    0  0.0   0:00.00 kblockd/0
    Code:
    Total DISK READ: 0.00 B/s | Total DISK WRITE: 0.00 B/s
      TID  PRIO  USER     DISK READ  DISK WRITE  SWAPIN     IO>    COMMAND
        1 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % init
        2 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [kthreadd]
        3 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [migration/0]
        4 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [ksoftirqd/0]
        5 rt/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [migration/1]
        6 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [ksoftirqd/1]
        7 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [events/0]
        8 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [events/1]
        9 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [cpuset]
       10 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [khelper]
       13 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [netns]
       16 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [async/mgr]
     3601 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % [flush-9:1]
     3602 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % sshd: [email protected]/2
     3119 be/4 root        0.00 B/s    0.00 B/s  0.00 %  0.00 % top

Similar Threads

  1. Server is lagging HARD
    By Arena Hosts in forum Hosting Security and Technology
    Replies: 13
    Last Post: 02-12-2010, 07:01 PM
  2. Server is Lagging PLEASE HELP!
    By newbiedude85 in forum Hosting Security and Technology
    Replies: 4
    Last Post: 05-09-2006, 03:24 AM
  3. Server is Lagging like crazyyyy....
    By duckxtales in forum Hosting Security and Technology
    Replies: 14
    Last Post: 02-14-2006, 01:18 AM
  4. spam causing server lagging
    By alojamentonaweb in forum Dedicated Server
    Replies: 0
    Last Post: 11-18-2005, 12:02 PM
  5. Server Randomly Lagging
    By Jakiao in forum Hosting Security and Technology
    Replies: 7
    Last Post: 10-24-2005, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •