Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2010
    Posts
    325

    Ubuntu vps: ssh won't start

    Installed new Ubuntu 10.10 vps (Virtuozzo) and cannot ssh into it via port 22. The /etc/ssh/sshd_config file is there though

    [email protected]:~# service sshd restart
    sshd: unrecognized service
    Only apache2, sendmail, xinetd show up under services in vzpp.

    [email protected]:~# sudo apt-get install openssh-server
    Reading package lists... Done
    Building dependency tree... Done
    openssh-server is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Last edited by The Calling; 03-05-2011 at 07:46 AM.

  2. #2
    Join Date
    Feb 2011
    Location
    Kasultanan Ngayogyakarta
    Posts
    247
    use /etc/init.d/ instead service doesn't make different? see on your log first.
    Carstensz Pyramid Server
    ...:::::: KVM |||| VPS ::::::...

  3. #3
    Join Date
    Sep 2010
    Posts
    325
    What? I don't understand what you're trying to say

  4. #4
    Join Date
    Sep 2010
    Posts
    325
    [email protected]:/etc/init.d# ./ssh start
    * Starting OpenBSD Secure Shell server sshd
    Still cannot ssh into port 22.

    Connection timed out

  5. #5
    Join Date
    Feb 2011
    Location
    Kasultanan Ngayogyakarta
    Posts
    247
    sorry, my bad.

    use /etc/init.d/sshd or ssh restart

    and try to look at your system log on /var/log/ directory (maybe on syslog file)

    and use nmap on your home pc to check if port 22 not closed.
    Carstensz Pyramid Server
    ...:::::: KVM |||| VPS ::::::...

  6. #6
    Join Date
    Sep 2009
    Posts
    1,794
    Check with "netstat -anlp" if ssh is listening on port 22.
    LVPSHosting.com|Virtual Private Servers|Dedicated Servers|
    Managed Hosting Solution|24/7/365 Support
    Datacentar and servers location: Holland, Europe

  7. #7
    Join Date
    Aug 2010
    Location
    St-Petersburg Russia
    Posts
    11
    1. Check if sshd is running 'ps x | grep sshd'
    2. Try to connect to it from your localhost 'ssh localhost'

    If all of this ok, you have problem between you local computer and server, you can try to change standart 22 port of sshd to other in /etc/ssh/sshd_config (uncoment line with #Port 22 and change port number). Don't forget to restart sshd after this '/etc/init.d/sshd restart'. And try to connect to new port from your local ssh client.

Similar Threads

  1. Virtuozzo Ubuntu Template Won't Install
    By The Calling in forum Hosting Software and Control Panels
    Replies: 1
    Last Post: 03-03-2011, 07:28 PM
  2. Host won't enable SSH on dedi server
    By dhybrid in forum Dedicated Server
    Replies: 55
    Last Post: 10-23-2010, 07:51 PM
  3. Any Tutorial To Start SeedBox On Ubuntu 10.04 ?
    By X-Dev in forum VPS Hosting
    Replies: 7
    Last Post: 08-31-2010, 09:56 PM
  4. hypervm vps won't start
    By hostcadet in forum Hosting Security and Technology
    Replies: 9
    Last Post: 01-06-2010, 06:05 PM
  5. My XP won't start
    By hardjoko in forum Computers and Peripherals
    Replies: 15
    Last Post: 05-09-2007, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •