Results 1 to 17 of 17
  1. #1

    High Server Load and Less Memory Useage?

    Hello,

    My website (Active vBulletin Board + Inactive WP Blog), with total of 3 - 5k visitors daily, are currently hosted with VPSLatch. Yesterday, all of sudden the load of the VPS on which I am hosted shot up drastically high. I asked for help, but my host informed that it's me due to which it's happening. I'm little surprised and afraid because things were doing just perfectly fine then howcome an issue like this cropped up suddenly, when the activity on my board was normal like any other day. The only major plugin that I have been using is vBSEO (Since a Year), I turned it off. Infact, I turned off all the plugins, yet the server load was very high BUT the memory usage is less (As usually it is). So, I would like to know whether the problem is from my end or from the server's? Because, when the memory usage is less, I'm sure that upgrading the RAM will be of no help either but I need some solution as soon as possible, because my website is loading extremely slow now.

    Thanks, and looking forward for some helpful responses.
    Attached Thumbnails Attached Thumbnails load-vps.png  
      0 Not allowed!

  2. #2
    Have you tried checking top -c to see where the usage is coming from?
      0 Not allowed!

  3. #3
    Join Date
    Aug 2010
    Location
    New Jersey
    Posts
    65
    Its probably a combination of yourself along with the other fine folks hosted on your server. High load is just a measure of how many processes are waiting in the Q. As other VPS' use more load, your server begins to fall behind thus you can shoot up even if your just using your usual amount of CPU resources. I would ask to be moved to another node or possibly seek another provider. Just my 2 cents.

    Good luck.
    www.BigScoots.com - Experience the Difference, Ride With Us
    Specializing in VPS and Shared Hosting | Free Server Migrations
    Fully Managed | RAID10 Dual Quad Core Systems
    REAL 24/7/365 US Based Support | 99.9% Uptime Guarantee
      0 Not allowed!

  4. #4
    Quote Originally Posted by LoyaltyV View Post
    Have you tried checking top -c to see where the usage is coming from?
    VPSLatch sent me this (I'm posting only excerpt). vBSEO could be the issue BUT:

    - Earlier also it was same, yet the website was working perfectly well.

    - Even if it is vBSEO, why the load is staying high despite of turning it off?

    top - 15:52:15 up 4 days, 6:29, 0 users, load average: 37.82, 21.27, 11.93
    Tasks: 161 total, 34 running, 106 sleeping, 0 stopped, 21 zombie
    Cpu(s): 6.6%us, 6.3%sy, 87.2%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
    Mem: 1048576k total, 847112k used, 201464k free, 0k buffers
    Swap: 0k total, 0k used, 0k free, 0k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    7903 *account name* 20 4 31284 16m 5728 R 10.8 1.6 0:01.39 /usr/bin/php /home/*account name*/public_html/forums/vbseo.php
    10126 *account name* 20 4 0 0 0 Z 7.6 0.0 0:01.16 [php] <defunct>
    27686 *account name* 20 4 33900 19m 5760 R 7.5 1.9 0:03.43 /usr/bin/php /home/*account name*/public_html/forums/vbseo.php
    1675 *account name* 22 4 31800 16m 5736 R 6.8 1.7 0:03.06 /usr/bin/php /home/*account name*/public_html/forums/vbseo.php
    7439 *account name* 22 4 32552 17m 5756 R 5.6 1.7 0:02.57 /usr/bin/php /home/*account name*/public_html/forums/vbseo.php
    13844 *account name* 21 4 25360 9260 4812 R 5.0 0.9 0:00.29 /usr/bin/php /home/*account name*/public_html/forums/vbseo.php
    9448 *account name* 20 4 31284 16m 5724 R 4.7 1.6 0:01.48 /usr/bin/php /home/*account name* /public_html/forums/vbseo.php
    Quote Originally Posted by BigScoots View Post
    Its probably a combination of yourself along with the other fine folks hosted on your server. High load is just a measure of how many processes are waiting in the Q. As other VPS' use more load, your server begins to fall behind thus you can shoot up even if your just using your usual amount of CPU resources. I would ask to be moved to another node or possibly seek another provider. Just my 2 cents.

    Good luck.
    Thanks..
      0 Not allowed!

  5. #5
    Join Date
    Aug 2010
    Location
    New Jersey
    Posts
    65
    On another quick note, we had some forum folks who downgraded to a previous version of CentOS and had load issues. Things like that as odd as it might sound are not as efficent as some newer software versions. We ended up having to reinstall a newer version and rebuild apache, everything was dandy soon after.

    Point being, as with any basic desktop error, the support guy will say: "Do you have the newest drivers?" Well in this case, do you have all the newest versions of software?

    But again, all moot because of the fact its out of the blue. I fall back to my previous conclusion . Simply ask to be moved, there a large enough company for it to be a very simple and straight forward process.
    www.BigScoots.com - Experience the Difference, Ride With Us
    Specializing in VPS and Shared Hosting | Free Server Migrations
    Fully Managed | RAID10 Dual Quad Core Systems
    REAL 24/7/365 US Based Support | 99.9% Uptime Guarantee
      0 Not allowed!

  6. #6
    From the looks of that top output it seems VBESO is spawning dozens of PHP processes, I suggest you ask VPSLatch to optimize Apache/SQL for you, it can make a world of difference.
      0 Not allowed!

  7. #7
    Join Date
    May 2009
    Location
    US
    Posts
    2,502
    Quote Originally Posted by LoyaltyV View Post
    From the looks of that top output it seems VBESO is spawning dozens of PHP processes, I suggest you ask VPSLatch to optimize Apache/SQL for you, it can make a world of difference.
    It looks like that might very well be the case here.

    A lot of vBSEO processes are coming from his VPS, according to top and ps aux.

    Code:
    [email protected] [/]# ps aux | wc -l
    149
    I'm seeing many, many lines in "ps aux" of vBSEO processes, here's a small snippet:
    Code:
    theauto2  3666  0.7  0.7  23760  8096 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3667  2.0  1.2  28552 12784 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3668  1.6  1.1  27264 12024 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3669  3.0  1.5  30984 16436 ?        SN   06:24   0:01 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3712  1.5  1.1  27264 12264 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3751  1.8  1.1  27264 12264 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3762  1.7  1.1  27264 12028 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3792  1.9  1.2  27784 12592 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3879  1.2  1.0  25684 10668 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3906  1.2  1.0  25684 10668 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2  3992  1.1  0.9  25356 10356 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2 23955  1.5  0.9  25356 10220 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2 23966  1.3  0.9  25360  9724 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    theauto2 23980  1.1  0.8  25360  9232 ?        RN   06:24   0:00 /usr/bin/php /home/theauto2/public_html/forums/vbseo.php
    Our support techs are investigating the issue further at hand and will update you shortly, but from the looks of it it looks like something with vBSEO.

    BigScoots has mentioned to request a server migration however we believe that won't help, since the high server loads are caused by your VPS not any other VPS on the node itself.

    Thank you for your cooperation into this matter. We will definitely keep you posted with our findings
      0 Not allowed!

  8. #8
    Hello Adam, So would upgrading the RAM to another GB resolve this problem?
      0 Not allowed!

  9. #9
    Voila! My account has been suspended even without properly guiding me and answering my queries inspite of the fact that I am absolutely ready to upgrade or do whatever and resolve this problem courteously. Sorry, but this is definitely not something that I expected from VPSLatch even after being a loyal client.
      0 Not allowed!

  10. #10
    Join Date
    May 2009
    Location
    US
    Posts
    2,502
    Quote Originally Posted by *VT* View Post
    Voila! My account has been suspended even without properly guiding me and answering my queries inspite of the fact that I am absolutely ready to upgrade or do whatever and resolve this problem courteously. Sorry, but this is definitely not something that I expected from VPSLatch even after being a loyal client.
    We have been discussing it with you via support ticket, and have suggested solutions to resolve your problem. We have suspended it temporarily for using a 50+ constant server load, but it will be unsuspended once we discuss this via ticket #457437.

    While I understand you are frustrated at us, this issue seems to be something with vBSEO. I responded to your ticket asking for some more information so I can reach a conclusion. Thanks for being a loyal client, I'm confident we'll be able to reach some sort of conclusion into this issue.

    If you would like a phone call regarding this issue, please let me know.
    Last edited by VL-Adam; 02-26-2011 at 03:28 AM.
      0 Not allowed!

  11. #11
    Join Date
    Nov 2005
    Location
    Portland, Oregon
    Posts
    1,080
    Quote Originally Posted by *VT* View Post
    Voila! My account has been suspended even without properly guiding me and answering my queries inspite of the fact that I am absolutely ready to upgrade or do whatever and resolve this problem courteously. Sorry, but this is definitely not something that I expected from VPSLatch even after being a loyal client.
    I have been receiving the same treatment, three times the last three days in a row. Adam just replied to my ticket stating it won't happen again. We'll see...
    VPSFuze.com - Performance should be noticeable - VPS Hosting at its best.
    HostingFuze.com - Affordable & Reliable Shared & Master Reseller hosting services
      0 Not allowed!

  12. #12
    Join Date
    Jan 2011
    Location
    India
    Posts
    1,446

    *

    Try to contact them again by clarifying right from the first sentence. I am sure you will get answer back.
      0 Not allowed!

  13. #13
    Adam has responded to my ticket and we are currently discussing about this issue..
      0 Not allowed!

  14. #14
    Join Date
    May 2009
    Location
    US
    Posts
    2,502
    *VT*,

    Your issue should be resolved now, and I have updated your ticket. If you require any further assistance, please submit a support ticket and we would be more than happy to assist you!

    Thanks a lot for your cooperation while we investigated the issue.

    - Adam
      0 Not allowed!

  15. #15
    Phew!! Finally. Thanks Adam. Good to see my website back. Though I'd still like to know why did the vBSEO started to act strange and consume so many resources suddenly. My site seems to be loading well.
      0 Not allowed!

  16. #16
    Join Date
    May 2009
    Location
    US
    Posts
    2,502
    I updated your ticket

    We can communicate there. I'm glad things are resolved at this time.

    - Adam
      0 Not allowed!

  17. #17
    Alright. Mods may now close this thread.
      0 Not allowed!

Similar Threads

  1. High Server Load! Swap and memory usage!
    By webhostbeginner in forum Hosting Security and Technology
    Replies: 5
    Last Post: 11-20-2007, 04:26 AM
  2. Server Load is high but Memory Used is low
    By sakibin in forum Dedicated Server
    Replies: 4
    Last Post: 05-08-2006, 12:58 PM
  3. Odd... High Memory + Server Load
    By Ricjustsaid in forum Hosting Security and Technology
    Replies: 7
    Last Post: 11-20-2005, 10:07 PM
  4. High server load, low memory usage
    By Platypus101 in forum Hosting Security and Technology
    Replies: 12
    Last Post: 09-27-2005, 04:35 AM
  5. server high load & eating memory
    By qatarson in forum Hosting Security and Technology
    Replies: 11
    Last Post: 06-12-2005, 01:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •