Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2006
    Posts
    43

    How do I grant privilege for MySQL on CentOS 5 32bit?

    My VPS is running on CentOS 5 32bit with Kloxo installed.

    I have created the database in Kloxo. But I can't seem to find information on how to grant privilege for the database.

    I would like to grant all privilege to one of my databases, how do I do that?

    Thank you in advance.

  2. #2
    Join Date
    Dec 2006
    Posts
    43
    Nevermind. Figured it out. I didn't know I could do it through phpMyAdmin.

  3. #3
    Nice to hear you figured out it. You can do it via command line as well.

    You will start by logging into your server via ssh and logging into your MySQL entering the following:

    mysql u root p

    Your prompt should now look like this:

    mysql>

    Enter the following:

    GRANT SELECT ON database.* TO username@'localhost' IDENTIFIED BY 'password';

    To enable more options you would separate them with a comma. So to enable SELECT, INSERT, and DELETE your
    syntax would look like this;

    GRANT SELECT, INSERT, DELETE ON database.* TO username@'localhost' IDENTIFIED BY 'password';

    Once you have given the desired privileges for your user, you will need to run this command within the MySQL
    command prompt;

    FLUSH PRIVILEGES;

    To see a list of the privileges that have been granted to a specific user;

    select * from mysql.user where User='user' \G

  4. #4
    Join Date
    Dec 2006
    Posts
    43
    Before I found out I could grant privilege for MySQL through phpMyAdmin, I was looking for command prompts. But none of them worked.

    I tried mysql –u root –p
    There is no response. :/ I hit enter after finishing typing the prompt, but nothing shows up. I could still edit the prompt even after hitting enter.

    I don't know if I am supposed to install MySql via Yum in the console or what. Some sites provide codes to install MySql but states only if there is no other software installed. Since I have already installed Kloxo (which has database management) I assumed that MySQL is installed. Please correct me if I am wrong.

    Thank you

  5. #5
    Join Date
    Dec 2006
    Posts
    43
    Oh. I think my browser kept on getting stuck when I was accessing the console window, which is why the command prompt didn't go.

    Thank you for the prompts !

Similar Threads

  1. centOS 5x but 32bit or 64bit?
    By antondb in forum Dedicated Server
    Replies: 3
    Last Post: 09-03-2008, 01:43 PM
  2. CentOS 32bit or 64bit
    By ckissi in forum Dedicated Server
    Replies: 12
    Last Post: 01-30-2008, 08:32 PM
  3. centos 5 32bit server
    By ti_nhatrang in forum Hosting Software and Control Panels
    Replies: 1
    Last Post: 09-26-2007, 06:09 AM
  4. CentOS 32bit to CentOS 64bit
    By TonyB in forum Hosting Security and Technology
    Replies: 4
    Last Post: 06-08-2005, 01:49 AM
  5. MySQL - How to grant FILE privilege?
    By hostchamp in forum Hosting Security and Technology
    Replies: 11
    Last Post: 02-15-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •