Results 1 to 18 of 18
  1. #1
    Join Date
    Aug 2008
    Posts
    492

    Arrow sshd has failed, please contact the sysadmin.

    Hi,

    I am not able to connect to SSH using putty & getting below error

    PuTTY Fatal Error
    Network Error: Connection Timed out.
    I have tried to restart SSH Daemon from WHM
    Main >> Restart Services >> SSH Server (OpenSSH)

    but i am also getting error
    Restarting SSH Daemon

    Waiting for sshd to restart..............finished.

    sshd (/usr/sbin/sshd) running as root with PID 24098

    Nov 30 11:53:26 saturn sshd: sshd shutdown succeeded
    Nov 30 11:53:26 saturn sshd: succeeded
    sshd has failed, please contact the sysadmin.
    Please help me out to resolve this issue.

  2. #2
    Join Date
    Sep 2009
    Posts
    1,779
    LVPSHosting.com|Virtual Private Servers|Dedicated Servers|
    Managed Hosting Solution|24/7/365 Support
    Datacentar and servers location: Holland, Europe

  3. #3
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    Quote Originally Posted by LVPSHosting View Post
    Tried, but issue is still same as it is.

  4. #4
    Join Date
    Apr 2009
    Posts
    184
    run command below,
    /scripts/restartsrv_sshd
    /etc/init.d/sshd restart
    Offering Reliable Shared, Reseller, Master Reseller and Shoutcast Hosting.
    High Performance VPS Hosting with 99.9% Uptime.
    Providing
    Hosting Since 2006 Locally and Since 2008 Globally.

  5. #5
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    Quote Originally Posted by linux2k View Post
    run command below,
    /scripts/restartsrv_sshd
    /etc/init.d/sshd restart
    I mentioned when i post this thread that

    I am not able to connect to SSH

  6. #6
    Join Date
    Jun 2010
    Posts
    271
    what about a server reboot? it almost fix all problems. I know its not a proper solution but you can give it a try.
    Last edited by akasharya; 11-30-2010 at 05:50 AM.

  7. #7
    Join Date
    Sep 2002
    Location
    Chicago, Illinois
    Posts
    882
    Is the machine running out of disk space? This can cause services to fail at times.

    Do you have KVM console available? This would allow you to get into console and do further diagnostics.
    Neosurge Web Services since 2002
    Neosurge VPS Hosting

  8. #8
    Join Date
    Jun 2010
    Location
    Indonesia
    Posts
    458
    Maybe you can try to kill the sshd process from the WHM :

    System health >> Process Manager >> sshd
    After that, try to restart the ssh server :

    Restart Services >> SSH Server (OpenSSH)
    Then try to login again using your Putty. And please use the righ port you have opened for the ssh connection
    Last edited by Erawan Arif Nugroho; 11-30-2010 at 08:16 AM.
    www.erawanarifnugroho.com - my personal homepage
    www.ean.rocks - my server uptime monitoring

  9. #9
    Join Date
    May 2010
    Location
    India
    Posts
    78
    what is the server uptime? if its too long i would strongly suggest a reboot... you might have many hidden issues which will be automatically fixed during a reboot.

  10. #10
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    Quote Originally Posted by akasharya View Post
    what about a server reboot? it almost fix all problems. I know its not a proper solution but you can give it a try.
    already Tried but, problem is still same as it is.

  11. #11
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    Quote Originally Posted by Erawan Arif Nugroho View Post
    Maybe you can try to kill the sshd process from the WHM :



    After that, try to restart the ssh server :



    Then try to login again using your Putty. And please use the righ port you have opened for the ssh connection
    I tried by best
    I already killed SSH process from the process manager & restarted SSHD daemon from WHM but the result is still same as it is.

  12. #12
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    I am sorry to all of you, we got reinstalled CSF firewall but i forgot to open an alternate SSH port that's why i was not able to connect SSH server.

    further i have tried to restart SSH using following ways

    service sshd restart
    /scripts/restartsrv_sshd
    /scripts/restartsrv sshd
    /etc/init.d/sshd restart

    But i am still receiving same error while restarting SSH Daemon from WHM
    Main >> Restart Services >> SSH Server (OpenSSH)

    Please suggest me what do i do now.

  13. #13
    Join Date
    Aug 2010
    Location
    Canada
    Posts
    314
    WHM always shows an error if SSH is running on a different port other than default. It still restarts the service successfully though, I'm quite sure.

  14. #14
    Join Date
    Jul 2010
    Location
    India
    Posts
    92
    Try adding that custom port on WHM allowed ports list as you have WHM access.

    On most of the case CSF would completely block the server and you may need to contact DC Lol. But lucky you have WHM access. Try to add that custom SSH port and restart the firewall and SSH service then.

    I hope that could resolve it.

  15. #15
    Join Date
    Aug 2008
    Posts
    492

    Arrow

    Quote Originally Posted by elicitservers View Post
    WHM always shows an error if SSH is running on a different port other than default. It still restarts the service successfully though, I'm quite sure.
    Is there any solutions for that ?

  16. #16
    Join Date
    Aug 2008
    Posts
    492
    Quote Originally Posted by jeffmonte View Post
    Try adding that custom port on WHM allowed ports list as you have WHM access.

    On most of the case CSF would completely block the server and you may need to contact DC Lol. But lucky you have WHM access. Try to add that custom SSH port and restart the firewall and SSH service then.

    I hope that could resolve it.
    This issue is resolved by me view thread no 12 click here

  17. #17
    Join Date
    Apr 2009
    Posts
    184
    I think your ssh configuration is wrong.
    The best option at this time is contact your datacenter and him to reinstall SSH
    Offering Reliable Shared, Reseller, Master Reseller and Shoutcast Hosting.
    High Performance VPS Hosting with 99.9% Uptime.
    Providing
    Hosting Since 2006 Locally and Since 2008 Globally.

  18. #18
    Join Date
    Jul 2010
    Location
    India
    Posts
    92
    Either you mat try enabling the custom ssh port which you have configured for ssh on csf via WHM. Else you would have to contact DC, as you have no other choices unless you have a KVM access to your server.

  19. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Similar Threads

  1. httpd has failed, please contact the sysadmin.
    By Virtuoso Host in forum Hosting Security and Technology
    Replies: 5
    Last Post: 06-09-2008, 04:14 PM
  2. sshd has failed, please contact the sysadmin
    By X-x-X in forum Hosting Security and Technology
    Replies: 5
    Last Post: 01-15-2008, 03:18 PM
  3. httpd has failed, please contact the sysadmin
    By khalijhost in forum Hosting Security and Technology
    Replies: 13
    Last Post: 06-11-2007, 10:49 AM
  4. succeeded sshd has failed, please contact the sysadmin.
    By robocap in forum Hosting Security and Technology
    Replies: 3
    Last Post: 05-23-2007, 02:56 AM
  5. httpd has failed, please contact the sysadmin.
    By MarsNIIT in forum Hosting Security and Technology
    Replies: 6
    Last Post: 04-14-2006, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •